Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am following Mohamed Mansour's directions from this reference to enable user scripts in Google Chrome. But I can't seem to get them working, and I am sure I am missing something obvious.

Specifically:

  • I updated the Chrome shortcut with the --enable-user-scripts option.
  • I created the a test script (below) in C:\Users\zoredache\AppData\Local\Google\Chrome\User Data\Default\User Scripts called test.user.js.
  • I killed all existing Chrome processes and restarted.

test.user.js

// ==UserScript==
// @name  Test Script
// @include  *
// ==/UserScript=
alert("Hello World!");

I am running Chrome 5.0.375.127 on the 64 bit version Windows 7 Professional.

I believe I have completely followed the directions, but the alert() is never displayed when I try to visit pages.

So what do I have to do to enable user scripts in Chrome? What step am I missing?

share|improve this question
    
"test.users.js."...try dropping the s from users –  Moab Aug 30 '10 at 20:44
    
@Moab, Unfortunately, that was just a typo when I posted the question. The name of the script is/was test.user.js. –  Zoredache Aug 30 '10 at 20:53
add comment

1 Answer

up vote 2 down vote accepted

Chrome 5 shouldn't need a command-line switch to use userscripts anymore and the instructions you're following are nearly 18 months old. All you have to do is drop the user.js file into your Chrome instance and follow the prompts. Chrome has had this functionality since January.

share|improve this answer
    
I know that is out of date, but my searching on Google wasn't revealing anything newer. Do you have an up-to-date reference that you could add to your answer for completeness? –  Zoredache Aug 30 '10 at 22:50
1  
If you want to find recent stuff on Google, just click Show Search Tools in the sidebar of a Google Search and choose Past Year or another choice. Check out this Lifehacker article. –  digitxp Aug 31 '10 at 1:47
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.