Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Since I've been using Firefox on my 64-bit Windows machine, every few minutes the browser stops responding, with "Not Responding" in the title bar and the screen fades out for a few seconds.

I've googled this issue, and it appears other users are experiencing this too, with some suggestions that it's caused by the Flash plugin. I don't want to disable Flash, because I like to watch videos, so is there another way to solve this issue?

share|improve this question
    
The flash problem is not only in Firefox, I have noticed after installing flash lagging occures frequently, I only enable falsh when it is needed, I use IE mostly. –  Arjang Aug 30 '11 at 22:29

2 Answers 2

Assuming that you're using the latest version of Firefox (3.6.x), it splits Flash (and other plugins) into a separate process called "plugin-container.exe" that you can see in Task Manager separately from the main firefox.exe process, do you see that using a lot of resources when your Firefox freezes?

If not, then this may not directly be Flash freezing the browser.

(On another note, I have Flash and 32-bit Firefox running happily on 64-bit Windows 7 Enterprise and don't see these freezes)

Update in 2014

These days Mozilla have some knowledgebase pages on troubleshooting problems with the Flash plugin Adobe Flash plugin has crashed - Prevent it from happening again | Flash video won't play full screen on YouTube, Facebook and other websites. Though what fixed recent Flash not responding problems for me with Flash 13 on Windows 7 was Disabling Protected Mode in Flash 11.3.

The last resort option (that I followed) in Adobe's FAQ How do I troubleshoot Flash Player's protected mode for Firefox? is:

Last resort

Finally, if these problems are blocking you from using Flash Player we recommend, as a last resort, you either revert back to Flash Player 11.2 or temporarily disable Protected Mode. We strongly recommend that Protected Mode is manually enabled once this issue is resolved.

To revert to a previous version of Flash Player, please see this FAQ: How do I revert to a previous version of Flash Player?

To disable Protected Mode, add the following line to your mms.cfg file located in:

Windows 32bit: C:\windows\system32\macromed\flash

Windows 64bit: C:\windows\syswow64\macromed\flash

ProtectedMode=0

If the mms.cfg file does not exist, create one using any standard text editor (e.g.. notepad)

Depending on your operating system, you might need to first save the mms.cfg file to a writable location (such as your documents or desktop folder) and then copy the file into the destination folder using Windows Explorer.

To re-enable Protected Mode, simply remove the line from the mms.cfg file.

share|improve this answer
1  
yeah further investigation across the web is suggesting that this is a deeper problem than Flash. Resource Monitor is reporting that "One or more threads of firefox.exe is waiting to finish network I/O". But with that said, I wonder why this issue seems to manifest itself after I activate Flash. I don't recall trouble like this with IE6 on XP :-) –  DaveDev Sep 13 '10 at 22:58

Yes there is. Adobe has got a special website about this problem. You will need to install and use a 32-bit browser to resolve this problem.

share|improve this answer
2  
I'm already using 32-bit firefox though.. so I don't think this is it –  DaveDev Aug 30 '10 at 22:30
    
so, maybe it isn´t the browser with flash causing the problem after all. Or is the problem gone if you disable flash for testing purposes? –  Diskilla Aug 30 '10 at 23:29

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.