Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

When I put the a CD in the CD drive, my laptop is not recognizing the CD anymore.

What could I do?

share|improve this question

migrated from Aug 5 '09 at 2:00

This question came from our site for system and network administrators.

closed as not a real question by random, quack quixote, Ivo Flipse Mar 17 '10 at 11:43

It's difficult to tell what is being asked here. This question is ambiguous, vague, incomplete, overly broad, or rhetorical and cannot be reasonably answered in its current form. For help clarifying this question so that it can be reopened, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

Please provide more detail. What kind of CD? Is it a burnt CD? Is it running Windows? XP? Vista? Linux? RHEL? FreeBSD? Was it burnt as a mastered disc or UDF? – Mark Henderson Aug 5 '09 at 1:49
What kind of laptop? Does the CD drive show up in device manager? Is the driver installed?... I don't think this question could be any more vague. – John T Aug 5 '09 at 2:09
i doubt Jason Ochs, a 1pt'er on SF will know that his question is here to answer the posted comments. – akf Aug 5 '09 at 2:13
  1. Try another CD
  2. Try the same cd on another machine
  3. if either (1) or (2) worked you know where the problem is - in the CD or in the drive

Post back the results so we can answer you again.

share|improve this answer

That also happened to me. Then I realized I should put the CD with the shiny face down. :D

share|improve this answer

I am not able to understand what the specific problem is on this, but will give some solutions that might be helpful.

Solution 1:
Go into Device Manager, uninstall the drive then reboot. Let Windows find it while it boots up.

Solution 2:
Change the CD and check with any other CD (the CD should have some content at least for verification )

Solution 3:
Is this a new or old CD-ROM drive?

Are the ribbon cables connected and is the power to the CD-ROM connected?

If new, are the jumpers right?

Solution 4:
Right click on the drive in My Computer; click on the Record Tab; check the box Enable CD recording on this drive. This solved the problem on all of my CD drives by checking that one box.

Solution 5:
Boot into SAFE MODE and real DOS and try to access

Solution 6:
If you have XP that is:

  1. Start with opening the file sysoc.inf in the folder C:/WINDOWS/INF
  2. Change the line:



  3. Go to Start > Settings > Control Panel > Add/Remove Programs > Windows Setup, uncheck Multimedia if it is checked, click OK, and reboot.

  4. Go back to the same place, recheck Multimedia so that it is white and checked, click OK, and reboot. If the Multimedia is NOT checked, just check it and reboot.

Solution 7:
Click Start / Run and type in regedit then navigate to:


Check for values named:


Delete them. Reboot the system.

Solution 8:
Reboot the machine and enter the BIOS. See if the CD drive is recognized there. If it's not, shut down, open the case and disconnect and then reconnect the cables attached to the drive. Make sure they are seated well, if any connections are loose, the drive won't work.

Solution 9:
Clean the CD lens using a CD lens cleaner disk.

If nothing works, change the drive and retest with a new drive.

share|improve this answer