Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I spent the night tweaking my computer running windows 7. I got a little performance gains but unfortunately, the Win-key keyboard shortcuts no longer work.

How do you fix them? What service requires them?

I'm mainly interested in the ones that move and re-size working window to half the screen.

share|improve this question

Check this:

Go to Windows' "Ease of access center" by typing that exactly on START menu's search box.(or, just press WIN+U)

Find and click "Make the keyboard easier...".

Uncheck the box with "Prevent...." under "Make it easier to manage windows" if it is checked.

share|improve this answer
1  
Thank you so much! For the longest time I thought these shortcuts required Aero (gross!), so I gave up, even though they were neat shortcuts. Then they worked on my computer at work even without Aero on. This was indeed the issue. :) – neminem Jul 13 '13 at 0:13
1  
It was unchecked for me, had to check it, hit apply, then uncheck it and re apply to fix the problem. – GrimurD Dec 20 '15 at 14:48
1  
I would say this is an answer to a slightly different question. If 'prevent...' is checked then the windows do not snap, irregardless of whether it is the keys or the mouse that try to snap them. However, I am experiencing a differnt problem, in that the mouse can snap windows, but the window key+arrow keys cannot, And yes, my windows keys works in itself... (brings up the windows task menu, e.g.) – alexandre iolov Feb 10 at 8:16

That feature is called "Aero Snap" and here is a webpage about how to enable and disable it :) http://www.winhelponline.com/blog/enable-and-disable-aero-snap-docking-windows-7/

share|improve this answer
2  
For anyone who runs into this issue in the future and ends up here, like I did: Aero Snap is not required. You can totally get these shortcuts back even in classic theme. The answer under this one is correct: it's the accessibility option under keyboard options to "prevent windows from being automatically arranged" that disables these shortcuts. – neminem Jul 13 '13 at 0:12

FYI - The full path to enable the windows+[arrow] function is: Control Panel\All Control Panel Items\Ease of Access Center\Make it easier to focus on task -- (keyboard works too as mentioned originally - they both take you to the same place).

Then you have to scroll down to heading that says "Make it easier to manage windows". This threw me off at first because the window doesn't look like there's any more content. So scroll down against your better instincts, then the full name of the "prevent" feature listed above is "Prevent windows from being automatically arranged when moved to the edge of the screen" -- make sure it's unchecked... I had to uncheck, recheck, uncheck to get my shortcut to start working again.

share|improve this answer

After following all of the advice listed (turning on and off all functions in the Windows "ease of access centre" I still didn't get it to work... until:

Reboot AGAIN after you toggle everything ON, APPLY, toggle OFF, APPLY

Then reboot.

Crazy, but it worked!

share|improve this answer
1  
Answers are really intended to be complete solutions, with each answer contributing a different solution. Tweaks to answers should be done in a comment (requires a little more rep), or as a suggested edit. Just a heads up--"non-answers" tend to attract downvotes. – fixer1234 Apr 16 at 22:40
    
This is really a comment and not an answer to the original question. To critique or request clarification from an author, leave a comment below their post - you can always comment on your own posts, and once you have sufficient reputation you will be able to comment on any post. Please read Why do I need 50 reputation to comment? What can I do instead? – DavidPostill Apr 17 at 9:00

When I disabled the aero snap feature, which I did not like, the hotkeys for multi-monitor windows management quit working.

When I followed up to enable these (windows shift and arrow) hotkeys, I found "prevent windows ... edge of the screen" box was checked.

Unchecking "prevent windows ... edge of the screen" did re-enable the windows management hotkeys and unfortunately the snap feature which I did not like was also re-enabled.

So this setting apparently does more than disable the annoying snap-to feature, it also disables the useful keyboard shortcuts.

share|improve this answer

For me the culprit was ConEmu's icon in the system tray. Closing it or simply clicking on it made the keyboard shortcut work again.

PS: this never happened before I updated to ConEmu 160619 [64]

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.