Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I got a CD of JPG files from a photographer. Some of the files are not readable on my Ubuntu machine (they show up as X icons in the Nautilus file browser). I figured out that the reason is that they are not "world-readable" (and also not "group-readable") and they are owned by a user that does not exist on my machine. I am able to work around it by doing

sudo nautilus

Is there any easier way to do this? I am thinking some setting I can make on my system relating to the CD driver works?

share|improve this question
add comment

2 Answers

up vote 2 down vote accepted

Passing the norock option to mount will disable Rock Ridge extensions and suppress the permissions recorded on the disc.

share|improve this answer
    
cool... how do I change that in the boot sequence? –  JoelFan Aug 31 '10 at 14:32
    
@JoelFan: You don't need to change the boot sequence, simply remount the drive with the norock option. Simply look through the first bit of the mount manpage. (man mount) –  Hello71 Aug 31 '10 at 14:44
    
@Hello71, I want it to mount the CD drive like that automatically when it boots. Otherwise I have to remount it manually each time –  JoelFan Aug 31 '10 at 22:34
    
No, you don't. Mount it once, copy the files off it, throw the disc in the circular file, then slap the photographer. –  Ignacio Vazquez-Abrams Aug 31 '10 at 23:06
    
@Ignacio, do you have any idea how they ended up that way? Only some of the images, not all! The photographer uses a Mac in case that sheds any light. –  JoelFan Sep 1 '10 at 1:23
show 3 more comments

Here are the commands to mount "norock":

me@desktop:~$ mount | grep cdrom  # find out the device and mount point
/dev/sr0 on /media/cdrom0 type udf (ro,nosuid,nodev,utf8,user=me)
me@desktop:~$ sudo umount /media/cdrom0 # unmount the mount point
me@desktop:~$ sudo mount -t iso9660 -o norock /dev/sr0 /media/cdrom0 # mount with "norock"
mount: block device /dev/sr0 is write-protected, mounting read-only
me@desktop:~$ 
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.