Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have installed Xampp to use wordpress, but after installing Xampp with Apache, MySql running.....I go to the browser and type "http://localhost", nothing happens, just blank screen.

My apache server was not running, I came to know that IIS was the problem and had to disable it.

Could anyone solve this issue as the http://localhost is not working to make xampp and wordpress run.

Below is the Port-Check results >

RESULT
------

Service Port Status
==============================================================================
Apache (HTTP) 80 Program: C:\xampp\apache\bin\httpd.exe
Apache (WebDAV) 81 free
Apache (HTTPS) 443 Program: C:\xampp\apache\bin\httpd.exe

MySQL 3306 Program: C:\xampp\mysql\bin\mysqld.exe

FileZilla (FTP) 21 free
FileZilla (Admin) 14147 free

Mercury (SMTP) 25 free
Mercury (POP3) 110 free
Mercury (IMAP) 143 free
Mercury (HTTP) 2224 free
Mercury (Finger) 79 free
Mercury (PH) 105 free
Mercury (PopPass) 106 free

Tomcat (AJP/1.3) 8009 free
Tomcat (HTTP) 8080 free

Press <Return> to continue.
share|improve this question
    
seemingly silly question, but what browser are you running? some browsers handle localhost differently, and in particular, Chrome is not always able to hit it when there is not an active internet connection. –  Jonathan Aug 31 '10 at 14:02
    
Would be a better fit for ServerFault, methinks? –  Kevin M Aug 31 '10 at 15:05
    
Jonathan - "seemingly silly question" > If it is a silly question i wouldn't have posted it here, i would have just used my common sense to solve this problem. I use Firefox browser, same problem in Opera, IE! Not using Chrome. Do you have any solution for the "silly question" again?? –  user7370 Aug 31 '10 at 15:25
2  
I think Johnathon was stating that his question about which browser seemed silly not your question... –  BillN Sep 13 '10 at 21:22
    
Just a thought, but do you already have some content inside your htdocs folder? I don´t know if there is something in there (i.e. index.html) by default –  Diskilla Sep 13 '10 at 22:15
show 1 more comment

3 Answers

Service              Port   Status
===================================
Apache (HTTP)          80   SYSTEM
Apache (WebDAV)        81   free
Apache (HTTPS)        443   SYSTEM

That's almost exactly what I'm looking at and mine is working. I would check your firewall, when IIS was running could you get to it? Also browse to http://127.0.0.1 if you can get to that link it may be a DNS/Hosts file issue. can you get to https://localhost ?

share|improve this answer
    
I have disabled the IIS, as Apache in Xampp was stopped after few seconds of starting it! 127.0.0.1 and localhost are blank again. –  user7370 Aug 31 '10 at 15:28
1  
Yeah, what I'm saying is before you disable IIS did localhost work? I'm trying to identify if it's an issue with XAMPP or your computer. –  Dan Williams Sep 1 '10 at 15:34
    
Nope, localhost didn't work before IIS was disabled, i had same problem then what am facing now, blank screen! –  user7370 Sep 1 '10 at 21:54
add comment

Enable the display_errors PHP configuration option so that you can see the error(s) that the PHP engine is trying to show you.

share|improve this answer
    
How do i do that?? –  user7370 Aug 31 '10 at 15:25
    
Edit php.ini in a text editor. –  Ignacio Vazquez-Abrams Aug 31 '10 at 23:05
    
okay! but what should i change here to enable > ; display_errors ; Default Value: On ; Development Value: On ; Production Value: Off ; display_startup_errors ; Default Value: Off ; Development Value: On ; Production Value: Off –  user7370 Sep 8 '10 at 14:42
add comment

What happens if you try to load the page from another PC? Try http:\computername or http:\ipaddress.

Also is Wordpress configured to be in the root directory. I think by default it is something like, http:\localhost\blog

share|improve this answer
    
Nope, i don't have another PC. For wordpress to work, i need to configure Xampp first, that itself is not loading, any solution? –  user7370 Sep 15 '10 at 18:12
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.