Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to set up a SLIP link using a serial connection between two XP computers. This is to test some specialized communications hardware that only supports IP via SLIP.

As a starting point, I'm simply connecting the two computers with a null modem cable to verify the SLIP connection is working. I configured the Guest computer's SLIP connection following this guide.

I have not found a comparable guide for configuring the host side, but I tried to create a complementary procedure: Network Properties / New Connection / Set up an Advanced Connection / Connect Directly To Another Computer / Host / COM1 / {choose users} / {finish}. This results in a new section in Network Properties labeled "Incoming" which has an item named "Incoming Connections".

After connecting the null modem between computers, I can successfully connect from the guest computer to the host. The Guest machine shows "Connected" in Network Properties, and I see the IP address in IPCONFIG. However on the Host computer, the status of the "Incoming Connections" device remains as "No Devices Connected". There is no new IP address in IPCONFIG, and there is no new interface in ROUTE PRINT.

On the Host machine, under Connection Properties / Networking / TCP/IP / Properties, there is a "Incoming TCP/IP Properties" dialog. I have set this for "Specify TCP/IP addresses, and I gave a range of 10 IP addresses in the 192.168.1.0 network. I checked "Allow Calling Computer to specify its own IP address", since per the PDF document (above) I specified an IP address (within this range of 10).

Since there is no IP address on the host machine, I can't PING across the link from the guest. What am I missing in this configuration for SLIP?

share|improve this question
    
Silly question - have you made sure you don't have that IP schema already on a network card? Have you also checked binding order? –  JNK Aug 31 '10 at 19:11
    
Both computers already have Ethernet networks on 192.168.0.0/24. I changed both SLIP connections to use 172.16.1.1 and 172.16.1.2. Same result: SLIP connection from Guest seems to connect, Guest gets an IP, but there is no evidence of any connection on the Host machine. Please explain how binding order would impact whether an IP address is assigned on the Host machine? –  tim11g Aug 31 '10 at 19:19
    
I deleted the host connection and recreated it following this sequence: Network Properties / New Connection / Set up an Advanced Connection / Accept Incoming Connections / COM1 / Do Not Allow VPN connections / {choose users} / {set TCPIP properties} / {finish}. No change - there is still no IP address on the host system when the Guest reports a successful connection. An LED monitor on the serial line shows traffic when attempting PING to another address on the 172.16.1.0 network. All pings time out, since there is no IP stack at that address on the Host. –  tim11g Aug 31 '10 at 19:40
    
I verified the serial connections by running terminals on both machines. The serial connection works fine. As an additional test, I reversed the host and guest roles. I get the same result - no IP address on the host. I can see the guest send bits to the host (on a serial LED monitor), but the host never sends to the guest. –  tim11g Aug 31 '10 at 21:15
    
I think this is the wrong forum - I'm moving the discussion to ServerFault: serverfault.com/questions/176984/… –  tim11g Sep 1 '10 at 15:09

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.