Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a wireless device named wlan0, and, after editing /etc/sysconfig/network-scripts/ifcfg-wlan0 I use ifup wlan0 to start wireless networking.

However, this fails often, typically by dhcpd failing, with errors in /var/log/messages like:

wlan0: link is not ready send_packet: Network is down

This is in Fedora 11. These same parameters worked fine in FC8. And NetworkManager/Gnome connects fine.

Does anybody have any idea why NetworkManager can connect to networks that ifup cannot?

share|improve this question

migrated from serverfault.com Aug 5 '09 at 3:59

This question came from our site for professional system and network administrators.

    
Is the NetworkManager service running when you try to manually configure the connection? When I tried to manually set my networks in F9, I'd run into a tug-of-war between my own configuration and NetworkManager –  Babu Aug 5 '09 at 3:41
    
pw for superuser is ewok.adventure –  Jeff Atwood Aug 5 '09 at 3:59

1 Answer 1

Fedora 10 / 11 (maybe 9 too) have moved away from network services being controlled by ifconfig etc to now use NetworkManager - the traditional tools [ifconfig, ifup, ifdown] aren't really treated in the same way anmore.

NetworkManager does things a bit different - you can have things controlled on boot / startup etc (I'm not totally across setting this up so can't give examples) but the config you need will live in /etc/NetworkManager/ Edit: NetworkManager uses a plugin to read distro specific configs Fedora/RH:/etc/sysconfig/network-scripts/ debian:/etc/network/ ...playing with files in /etc/NetworkManager is probably not the best idea after all.

To use the traditional network toolset you probably want to disable NetworkManager and use the network service instead:

http://www.mjmwired.net/resources/mjm-fedora-f11.html#network

make sure your ifcfg file has DEVICETYPE=wireless so that fedora uses the correct ifup command, the default behaviour is to use ifup-eth which generally doesn't really work for wireless.

share|improve this answer
    
The network service (/etc/init.d/network) also uses ifup, and it fails for the same reason. –  Bob Hooke Aug 5 '09 at 3:21
    
edited my reply after poking around NetworkManager a bit more - maybe just an ifcfg tweak needed. –  Disabled Leopard Aug 5 '09 at 3:43

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.