Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Yesterday I've tried to import another DUMP as a new Oracle schema and failed to to limited space. So the impdp exited with an error. I've successfully deleted outdated schemas using the sysadmin account and then tried to start the import again. Now it always throws the following error code and I've not yet found a solution (sorry for german output):

oracle@team1:~/admin/QS1/dpdump$ !impdp
impdp PARFILE=../scripts/ecg/userid.conf DUMPFILE=expdp_epl_prod__30-08-2010.dmp SCHEMAS=EPPROD REMAP_SCHEMA=EPPROD:LIVE_SQL_FINAL REMAP_TABLESPACE=EPL:USERS

Import: Release 11.1.0.7.0 - 64bit Production on Mittwoch, 01 September, 2010 9:44:44

Copyright (c) 2003, 2007, Oracle.  All rights reserved.

Angemeldet bei: Oracle Database 11g Release 11.1.0.7.0 - 64bit Production

UDI-31623: Vorgang hat ORACLE-Fehler generiert 31623
ORA-31623: Ein Job ist dieser Session nicht über das angegebene Handle zugeordnet
ORA-06512: in "SYS.DBMS_DATAPUMP", Zeile 2862
ORA-06512: in "SYS.DBMS_DATAPUMP", Zeile 4052
ORA-06512: in Zeile 1

translated error output:

UDI-31623: ORACLE error process has generated 31623

ORA-31623: A job is not assigned to this session via the specified handle

ORA-06512: in "SYS.DBMS_DATAPUMP", line 2862

ORA-06512: in "SYS.DBMS_DATAPUMP", line 4052

ORA-06512: in line 1

Any ideas what might be wrong and how I can fix this?

share|improve this question
add comment

1 Answer

Have you assigned the correct rights and roles ? Ensure you have assigned create session, create table, create procedure, imp_full_database to the user importing the dump file.

Also, assign read and write rights to the datapump directory.

grant read, write on directory <directory_name> to <user-name>

share|improve this answer
    
The user is sys! That error occurs since the broken import from before... all things have been setup properly. Oracle produces different errors since than. For example I'm also not able to export data using exp or expdp. –  Daniel Bleisteiner Sep 1 '10 at 13:32
    
@Daniel broken import ? What happens when you try to export using exp & import using imp ? –  Sathya Sep 1 '10 at 19:15
    
EXP-00056: ORACLE-Fehler 1455 aufgetreten ORA-01455: Überlauf von Integer-Datentyp bei Umwandlung der Spalte EXP-00000: Der Export-Vorgang endete mit Fehlern –  Daniel Bleisteiner Sep 2 '10 at 9:48
    
...just an example –  Daniel Bleisteiner Sep 2 '10 at 9:48
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.