Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have an NTFS partition mounted on my Ubuntu system. And one of my directories which conatians thousands of .xm music appears empty in Nautilus. When I try to list the contents using ls it says "reading directoy . : I/O error". However if I know the file's name I can access it and play it. If I boot into my Windows system I can view its contents without problems. What's going on and how can I resolve this issue?

share|improve this question
add comment

3 Answers

Blue screens and other system crashes can corrupt the file system structure. Also you can do some changes from Linux which you can't do on Windows plus if you don't use the latest NTFS driver, there might be bugs that corrupt the structure.

To be sure, have a look at this article on Wikipedia and run smartctl --all /dev/sda to list the SMART parameters of your driver (which will tell you whether the disk is failing or not).

share|improve this answer
add comment

After booting into my windows again the chkdsk checked the drive and fixed the errors... Now everything is working again.

It seems my HDD will fail soon... Or something other than hardware failure can cause filesystem errors?

share|improve this answer
    
I suggest to edit the question instead of posting an answer. –  Aaron Digulla Sep 1 '10 at 11:47
    
I second Aaron, you should edit question to update - and yes, LOTS of things other than hardware can cause file system corruption. Look around SU and you'll find more than you ever wanted to know about. –  hotei Sep 1 '10 at 15:56
add comment

There was a problem in Linux for a long time when trying to write to a NTFS partition (or mounting as RW the partition).
NTFS is a proprietary file system and, for a long time, writing to NTFS was at your own risk.

I think in recent distros the NTFS write is working.
I would suggest

  • Try to update to the latest Ubuntu 10.04.1
  • If you keep having the problem, mount the NTFS drive as read-only on Linux (/etc/fstab, as ro in options) in order not to corrupt your FS.
share|improve this answer
    
Last I heard, the NTFS-3g driver was more stable than the NTFS driver built into the kernel. I've been using it for a while with no problems. So I'd actually recommend installing ntfs-3g and putting that as the filesystem type in /etc/fstab instead of just ntfs. –  David Z Sep 1 '10 at 18:50
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.