Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I recently re-imaged my work machine after installing a new hard drive. After getting Windows 7 x64 installed and added to the domain, I found that many, almost all really, of the certs being issued to it where "bad" according to IE/Chrome (but not Firefox). This is wreaking havoc on any application I use that logs into a web sites, as the process generally uses SSL and relys on IE to supply the information about it.

Trying the usually fixes for something like this didn't work. Those included checking the time, and even changing it to something wrong and correcting it; clearing the certs in the system and letting them be reinstalled by the site; I even rebuilt the machine a second time hoping it would clear up the issue.

After the second rebuild, it worked while at home, not on the corporate network, but as soon as I joined it to the domain, any new cert it attempted to install came up as invalid. Any cert installed while I was off the domain still worked though.

What really made this situation odd is that a second machine I was building simultaneously has the same exact issue. I deploy computers on a regular basis and never ran into anything like this before.

Any help would be greatly appreciated, and thanks in advance.

share|improve this question
add comment

1 Answer

up vote 0 down vote accepted

So it turns out the issue had to do with the Root Cert Update. For whatever reason our Group Policy would not allow Windows Updater to download it. If you didn't update the Root Cert before joining the computer to the domain it wouldn't install it on it's own. There is a tool you can download that will force the Root Cert to update though. This solved my issue. It can be found here.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.