Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have created an Ad-hoc network between 2 computers based on these instructions.

I am connected to a LAN port in my hostel; all the rooms have one LAN port each. I want to share this connection with my roomie, and since we both have laptops I thought an Ad-hoc network ought to solve the problem - I've used this before but on another set of laptops.

Currently my computer (a Dell Inspiron 1525) is connected to the LAN port; my friend's computer is an IBM Thinkpad R51. I shared the LAN connection and next tried to follow all the above link's instructions but the Dell drivers don't give me the wireless networks option when I right click on Wireless network connection > Properties.

alt text

It only has the General and Advanced options, but there is another utility through which I created an Ad-Hoc network.

alt text

I also connected the other computer to this wireless network but my friend still can't browse the Internet through this connection. When I checked the packets of data on the wireless connection it has only sent some packets of data but can't receive any.

How do I solve this?

I know I could set up a network using a hub/switch but I don't want to invest further money into this as we are only here for a few weeks, and we both have the necessary hardware to network wirelessly.

share|improve this question
Not sure what your problem/quesion is, have you created an Ad hoc connection and are both computers connected to it? – Move More Comments Link To Top Aug 5 '09 at 6:21
Are you using Window to mange your wireless connection or a third party application that came with your dell? – Move More Comments Link To Top Aug 5 '09 at 6:23
Does your wired LAN connection have the hand under the icon. The one that indicates you are sharing the Wired connection? – Move More Comments Link To Top Aug 5 '09 at 6:50
Do you have any kind of network sharing enabled on the other laptop – Move More Comments Link To Top Aug 5 '09 at 7:38
open the cmd promt and ping from the slave laptop and post what happens – Move More Comments Link To Top Aug 5 '09 at 7:47
up vote 1 down vote accepted

You should be aware that the ad-hoc part of the 802.11 standard (wireless) is very poorly implemented by some wireless network device manufactures. Thus it is not uncommon at all to encounter two laptops which are simple incapable of communication with each other over an ad-hoc network.

I work with ad-hoc networks almost daily, I'm studying networks and distributed systems. And from experience with many poor ad-hoc implementations, we always make a point of using the same 802.11 hardware for all units we want to communicate in an ad-hoc network.

share|improve this answer

I have done this the other way around, by connecting an ethernet cable to my Xbox and sharing my Wireless internet connection. You should be able to do it the other way around.

You should open your Local Area Connection properly and check the "Share this connection" option. That will turn your wireless connection into a DHCP server that will other computers to connect and get an IP address. Your computer will act as a NAT and route traffic through the Ethernet.

share|improve this answer
i have checked the "share this connection" option on LAN and what do you mean by the other way around? – rzlines Aug 5 '09 at 6:24

Turn off firewall on both computers. If that works configure them to allow the connection and turn them back on.

share|improve this answer
nope, still nothing tried pinging too.. still getting the request timed out error – rzlines Aug 5 '09 at 8:38
should i manually enter settings in tcp/ip settings in the wireless adapter settings? – rzlines Aug 5 '09 at 8:50
You can try that, but the host computer should be handing out IP addresses for computer connected to the wireless network and the slave computer should connect using the settings of the host. Actually now that I think about it, put the proxy settings in the slave computer. – Move More Comments Link To Top Aug 5 '09 at 16:21
oh i got too fed up of debugging .. just went an bought myself a fast ethernet switch, thanks for all your help larry.. much appreciated – rzlines Aug 6 '09 at 10:45

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .