Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to share a some files on a Mac running Snow Leopard with a Ubuntu Linux.

The mount request gets a "permission denied", and a client system log contains "host xx requires a stronger authentication"

I've seen this problem referred to elsewhere, but no solution. This is a hack on a home network, and I really do want to "just do it" and damn the security flaws.

share|improve this question

migrated from stackoverflow.com Sep 1 '10 at 19:08

This question came from our site for professional and enthusiast programmers.

2 Answers 2

Same error here, except that the Linux instance is running in a virtual machine (QEMU). Adding -o nfsvers=3 does not help; mount -v clearly shows that protocol negotiation is occurring and successful.

The problem is that the mount request comes from an unprivileged port; putting

nfs.server.mount.require_resv_port = 0

in /etc/nfs.conf on the Mac and notifying the running server (sudo nfsd update) fixes it for me.

Note: here is what the man page has to say about that option—and its security implications:

 nfs.server.mount.require_resv_port
          This option controls whether MOUNT requests are required to
          originate from a reserved port (port < 1024).  The default value
          is 1 (yes).  Many NFS server implementations require this
          because of the false belief that this requirement increases
          security.
share|improve this answer

You are probably using NFSv4, which implements kerberos. Try specifying the nfs version for 3 in your mount command & see if it works. Also, you do know that UID/GID's need to be identical on both systems right?

share|improve this answer
    
You need to specify nfsvers=3. –  churnd Sep 13 '10 at 3:16

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.