Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

There is a strange bug with Aero Peek and Alt-Tab where the Alt-Tab window itself is sent all of the way to the back, and is obscured by whatever window may be being previewed in front of it. While it still works for switching tabs, it's extremely annoying to not be able to see what other windows are there. One solution I've found is to just disable Aero Peek, but I like the Aero Peek feature when it works, and want it enabled.

Let me reiterate, because every response so far doesn't seem to understand this:

I do not want to turn off aero peek. Do not give me an answer saying that I can disable it in the performance options. I will downvote your answer. Read every word of my question before you answer anything that involves the word "disable".

Some users of Lenovo products have found that uninstalling the "Thinkvantage communications" VoIP suite fixes it for them, but my laptop is an HP, not a Lenovo. The only VoIP software I have installed is Skype, which I removed to see if it had something to do with VoIP, but that didn't have any effect. I had seen this issue before on my old laptop, but it usually went away after a while, and always after a reboot. On my new computer (HP dm4t) it always occurs, and is driving me nuts.

If anybody can actually pinpoint what the problem is and more importantly how to fix it, I will be extremely thankful.

alt-tab failure
Window being previewed is in front of the Alt-Tab window

Update:

The issue seems to have randomly resolved itself, at least for now. I have no idea what changed, since I haven't made any modifications to the system between when it was broken and when it started working. Attached is another screenshot of it working properly, with the alt-tab window in front of everything else. I'd still like to know what causes this if anybody can determine it.

alt-tab correct

Update 2:

And now it's broken again...

Update with Windows 7 SP1:

The problem still occurs with Service Pack 1 installed. Still no idea what may be causing it.

share|improve this question
    
Does this happen on any other Windows 7 devices you have? –  digitxp Sep 1 '10 at 21:06
    
As I stated in the 2nd paragraph, yes I've seen this issue every once in a while on one of my other computers, but it would always go away after a reboot. On this computer the problem is always here. On a third machine I've never seen this problem. This is Win7 x64, the other two are 32-bit, but I don't think that should make a difference. –  nhinkle Sep 1 '10 at 21:08
    
I'm pretty sure it's a feature, not a bug. However, it's an annoying one. –  TuxRug Sep 1 '10 at 23:52
3  
It's absolutely not a feature. See my edit with the screenshot of how it's supposed to work. The entire point of the feature is for the alt-tab window to be on top so you can see what you're switching between; having it obscured like that would defeat the point of having it. –  nhinkle Sep 2 '10 at 0:48
add comment

2 Answers 2

up vote 3 down vote accepted

There seem to be two main (known) culprits here.

  1. Desktop Gadgets (sidebar.exe). If you can live without them, try disabling them:
    Right click desktop > select "View" > uncheck "Show desktop gadgets". This didn't work for me.
  2. Microsoft Intellipoint v8.1+. This was the solution that worked for me. It seems when they added support for the Microsoft Touch Mouse, the updated Intellipoint software introduced this bug. To fix it:
    Go to "Add or remove programs" and uninstall Microsoft Intellipoint. Instant fix, no reboot required.

If neither of those solutions work for you, I would try closing all open applications except for something innocuous, like notepad. Then open up your task manager and kill off suspicious processes one at a time until the problem is resolved. Obviously, make sure you don't kill a process that will destabilize your system. This could be a very tedious task.

This last post on the page in this thread helped me find the answer.

share|improve this answer
    
I haven't had this happen in a while, but I do have a Microsoft mouse, and thus the IntelliPoint drivers, so I'll try these tips the next time it happens. –  nhinkle Mar 14 '12 at 18:02
    
Very interesting... was using a sidebar gadget for the first time in months today, and what do you know? Alt-tab display goes to the bottom! Killed sidebar.exe, and problem goes away! I'll have to check it out on my desktop, too. –  nhinkle Mar 23 '12 at 6:57
    
So far these tips have fixed it every time the issue's popped up recently. Thanks for the help! –  nhinkle May 1 '12 at 18:24
1  
The process I had to kill was ACMon.exe, which is part of Asus Splendid Video. –  Sean Fujiwara Jul 15 '12 at 4:17
add comment

After reading this forum thread I found, they seem to have concluded that it's an OS bug.

The closest you may get to a (consistent) solution is to switch to something like VistaSwitcher.

Oh, and sue the heck out of Microsoft too.

share|improve this answer
    
I'd seen that forum thread previously, but was hoping there might be a better solution. I guess it's just broken; thanks for trying to help. Unfortunately, I doubt a lawsuit would fix anything. Hopefully this will get fixed in SP1. –  nhinkle Sep 3 '10 at 1:41
    
True (the lawsuit) but it does make you happy that you spend hundreds of dollars on lawyer fees and food near the court that could've gone to save hundreds and hundreds of people in Darfur :-). –  digitxp Sep 3 '10 at 3:46
add comment

protected by studiohack Mar 12 '11 at 20:58

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.