Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm getting some strange connection problems when trying to remote desktop to a Vista box. It connects and works for a while then disconnects with the following message:

"Because of an error in data encryption, this session will end. Please try connecting to the remote computer again."

Any help would be great!

share|improve this question
Are the two machines on the same LAN or are you connecting across a router, the Internet, etc? – boot13 Sep 2 '10 at 1:26
@boot13 The connection is via a VPN over the Internet. – Luke Quinane Sep 2 '10 at 1:40
Ah. Which VPN client are you using? You might want to read any documentation you can find on that client, looking for notes on using RDP. You could also use it to narrow down your search. Anyway, from what I've seen so far, this is one of those weird problems that a few people are having but nobody knows how to resolve (+1). – boot13 Sep 2 '10 at 5:22

From this thread,, it sounds like you may have your Vista computer setup in the router as the DMZ. Other suggestions are to delete any network protocols except the basics to see if that fixes it.

Hope this helps

share|improve this answer
the remote computer is just connected to a basic switch, no DMZ setting. Both local and remote PCs only have IPv4 and IPv6. – Luke Quinane Sep 2 '10 at 1:16

These answers are not correct, you can fix this by Simply uninstalling the Link-Layer Topology (Mapper I/O Driver and Responder) protocols, as well as the QoS Packet Scheduler service (you can add them back again afterwards) in the Local Area Connection of the client machine (not the server/target). You must uninstall, not simply remove the checkmark next to the protocol or service.

share|improve this answer
Anything to back that up? – Canadian Luke Jul 31 '13 at 22:25

My issue was resolved by starting the Link-Layer Topology service. It was previously set to Manual and was not started after I had reinstalled Windows 7.

share|improve this answer
Welcome to SuperUser. Your answer would be even better if you edit it to provide some explanation as to why your solution addresses the OPs question. – Twisty Dec 17 '14 at 21:05

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .