Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I don't really understand what the archiving really does in thunderbird but it is kinda annoying.

Like if I get a email and read it. It will turn to read in my inbox, but will show up as unread in my archives section.

So the next time I get an email the thunderbird notification will popup and show that I have 1 new email but will show all those unread one in my archive.

So even though I read all of the emails in my inbox the next time I get an email I get a popup notification of 6 messages when it should be 1 since 5 of those where in the archive and marked as unread.

Anyone know how to stop this?

share|improve this question
    
That's pretty darn close to my own question. But I don't have an answer for you :-(. –  digitxp Sep 2 '10 at 3:08
    
Please edit your question to indicate that this is a problem between Thunderbird and Gmail. That can be a big factor. –  Brock Adams Sep 3 '10 at 3:48
    
What Operating System (Mac OS or Windows) are you using? –  Leif Nov 8 '10 at 2:28
    
Windows 7 Ultimate edition 32bit –  chobo2 Nov 9 '10 at 0:30

4 Answers 4

up vote 1 down vote accepted

I have finally worked out how to resolve this (I went as far as getting the 3.3 beta of Thunderbird, but this should still work in 3.1)

  • Right click on the folder in the Archive (e.g. Archive -> Gmail), then click Subscribe...
  • Expand [Google Mail] ( or [Gmail] ).
  • Untick All Mail
  • Restart Thunderbird

You should notice the folder disappears from you archive entirely, if it doesn't (which happened on my Gmail account (basically none of the subscribe settings took effect), but the above worked for my google apps for domain account):

  • Remove the gmail account
  • Rename/Delete all the gmail/googlemail related folders in your profile (%appdata%\Thunderbird\xxxxxxxx.default\ImapMail on Windows)
  • Re-add the gmail account.
  • The above should now work.

Hopefully this gives you the desired outcome.

Ben

share|improve this answer
    
this seems to have done the trick! –  chobo2 Mar 27 '11 at 17:45

I suggest you create a filter rule on the Archive folder exclusively for all new or incoming emails to be marked as "read" on the fly.

share|improve this answer
    
How would I do that? –  chobo2 Nov 25 '10 at 18:54

The problem is, Thunderbird for whatever reason defaults to the All Mail folder for archives on GMail.

All Mail contains a copy of every message sent to you ever. Thus, on the Unified Folders view, every time you receive a new message, it also appears in the Archives view.

You can fix this by going to Tools, Account Options... then your account's Copies and Folders tab and clicking the radio button next to Archives on MailAccountNameHere.

This changes it to use the Archives folder on said account instead.

share|improve this answer
    
Ok I went their and right now beside the archive radio button it is sent to my email address one. What should I change it to? –  chobo2 Sep 14 '10 at 21:00

I think I found a solution that seems to work. It seems to be a problem with gmail and thunderbird.

hello all, i think i had the same pb but i fixed it. Let me sum it up : with my gmail accounts, i have the corresponding archive folder always full with tons of emails. Every mail I delete goes into the archive folder. If I

delete a mail form the archive folder, it comes back few minutes later. I think it is because Gmail archives all the deleted emails.

So, I went to my gmail account settings > Labs > Advanced IMAP Controls > activated. Once it is activated, goes to Settings > Forwarding and POP/IMAP > IMAP Access

Auto-Expunge : Do not automatically expunge messages > When a message

is expunged from the last visible IMAP folder: Immediately delete the message forever OR Move the message to the Trash

the magic happens : deleted emails from inbox and archive are gone forever :) i hope this helps

\m/ rocknroll for 2010

http://getsatisfaction.com/mozilla_messaging/topics/turn_off_archive

share|improve this answer
    
Just on a side note this only solves half my problems. If I don't want to delete the email then the achieve will stay as unread. So I need another solution to fix that problem. –  chobo2 Sep 2 '10 at 21:00

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.