Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I installed Ubuntu using Wubi on a Win-XP Dell laptop. Worked great, until I changed the display resolution to match the native resolution of an external monitor. After doing so, the gnome panels (the top and bottom bars) have disappeared. The gnome-panel process is still running, but I can't see the panels. When I kill the process it restarts immediately but nothing changes. Alt+F1 and Alt+F2 don't do anything in this state, so it's kind of useless. Any suggestions?

share|improve this question

2 Answers 2

External/secondary monitors don't show the GNOME panels... It might be possible that your monitor is set as secondary.

share|improve this answer
    
It is set as secondary; that seemed to be the only way to get the full resolution. Probably everything is visible on the primary (laptop) monitor; I'll confirm that. I don't really want to use both monitors, just one or the other. But I'd like the full 1920x1200 resolution on the external monitor when the laptop cover is closed. Maybe this needs to be a separate question, but in case there's any insight out there while this is still fresh, I'm adding the question here. When the monitors share the same display, the full resolution is not available. Is there a solution to that? –  Mark Davis Sep 2 '10 at 13:59
    
Confirmed. Turned off the laptop monitor (in the display settings) and now it works as expected. Thanks! –  Mark Davis Sep 4 '10 at 13:52
    
@MarkDavis You're welcome! ;) –  BloodPhilia Sep 4 '10 at 17:27

You are right! Originally I thought this is a bug and searched for solutions. Most say:

  • gconftool
  • rm -rf .gconf
  • pkill gnome-panel

However none of them worked.

I launched gnome-display-properties, found there are two monitors and turned off Laptop Monitor. The taskbars show up now!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.