Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've just installed Office 2010 Professional Plus (upgrading from Office 2007). It works fine under my admin account, but when I login with my wifes non-admin account, every time I open a document or start an app (Word, Excel, Publisher ...) Office 2010 goes through its configuration process (starting the the standard install dialog and then running the bootstrap process) before it loads the app - which wastes 2-3 minutes.

Once it's done this, the app runs fine and I can make setting changes that are remembered when it restarts, but I can't work out why it thinks it needs to configure the app each time.

Any thoughts?

share|improve this question
Maybe (just once!) try launching these from your wife's account elevated as an admin? Might be they need to do something that doesn't stick, and by allowing it to be an admin for one run could get the final config stages finalised? – DMA57361 Sep 2 '10 at 14:18
I agree with DMA - It's probably a permissions issue on her account that can't write to the appropriate system folder or registry entry. – JNK Sep 2 '10 at 14:28
Definitely related to this. I switched her account over and it works fine. But when I switch it back to non-admin, I get the same behaviour back again. Tried it on another account with the same outcome. – Rhys Gibson Sep 3 '10 at 8:52
Process Explorer shows me that it is installing components and running the .NET 3.5 addin a lot. – Rhys Gibson Oct 1 '10 at 21:10

OK, have had a little bit of a hunt...

MS Answers recommend the following suggestions:

  • Peform a "repair" on your Windows installation and the Office installation (although in the context of the linked discussion they were talking about Windows 7, not XP).

  • Re-install Office (including hints about how to remove Office completely first).

  • Check you don't have multiple version of Office installed.

share|improve this answer
Thanks; great links. I'll try it tonight. – Rhys Gibson Sep 4 '10 at 2:53
Still no joy. The clean ups definitely removed a bunch of stuff and I did a bit of a registry massacre looking for references to old Office versions, but with no luck. Next step will be to see if I can monitor the registry/handles as the app starts and work out which key/folder/file is being accessed. – Rhys Gibson Sep 5 '10 at 20:58
This link:… provides comments on how to fix this issue. Monitoring the event viewer and looking for events 1001 and 1004 from MsiInstaller gives specifics about the registry keys that are causing the problem. – Rhys Gibson Oct 17 '10 at 10:25
@Rhys since you've found a precise answer, you can add that information as a separate answer to your own question, and then tick it off as correct. This will make it easier for others with the same problem to find the solution in the future. – DMA57361 Oct 17 '10 at 17:19
up vote 2 down vote accepted

There are a number of other forums with similar problems. The issue I had seems to be registry related.

Others have solved the problem by completely removing previous versions of Office using the Office clean up process and reinstalling. The thread that @DMA57361 pointed to contains the full story.

In my case, I suspect some registry permissions were not left in a state that Office 2010 was expecting (e.g. non-admins not having Read access).

The solution is available here.

Looking into the Event Viewer after a failed startup gave me a list of events for the MsiInstaller. Messages 1001 and 1004 gave specifics about which registry keys were causing the problem. In the cases listed, it seems to be to do with the permissions on the various file type keys e.g. HKLM/Software/Classes/.msg. Giving non-admin users read access to these keys, sub-keys and values and ensuring that they are owned by an Administrator fixed the problem.

Note: The real answer is to rebuild the box and reinstall the OS too. Too many interactions between Office and Windows registry components.

share|improve this answer

I know this is an old post but I had the configuration issue for days and did not find an answer that worked for me so I would like to offer my experience in case there is someone like me looking for an answer.

I installed office 2007 pro and visio 2007 pro on a new 64 bit windows 7 system. It was all working fine for a few weeks. I then had the opportunity to install office 2013 pro (for $10 thorough job). I installed it and kept 2007 since 2013 did not include Visio and I use it a lot.

Few days later I needed to have Acrobat pro and so I installed my old copy of Adobe CS3.

Not long after I noticed the issue with configuration running every time Visio (and only Visio) started. Annoying as heck because it would run even if I had one instance running already and opened another with a different drawing!

After days looking for an answer I decided it had something to do with the Adobe add-ins running on Visio.

Solution - uninstalled both visio and adobe. Reinstalled Adobe first and got updates (had to reset system clock to Oct 1, 2011 to get updates!?)

Restarted and then reinstalled Visio. Voila! Everything working beautifully :)

Hope this helps someone!

share|improve this answer

I have the similar problem, read and tried all sort of recommendations, none of them fix the problem. According to the log, some how you do not have the administrative right even you are logged in as administrator.

I finally, fixed it for good: Created shortcuts from the "installed folder" and send to the Desktop. My is C:\Program Files\Microsoft Office\Office14\POWERPNT.EXE.

Then right click the shortcut > Properties > Shortcut >Advanced> Check "Run as administrator" >OK >OK.

Do the same routine to fix the other MS office components (Excel, WinWord, etc).

Enjoy it, no more reconfiguration again.

share|improve this answer

Alternate fix:

  1. Right-click Microsoft Word (or another MS Office application).
  2. Click Properties.
  3. On the Compatibility tab run Compatibility Troubleshooter.
  4. Then apply the fix.
share|improve this answer
Welcome to Super User! Can you be more specific about how to "run the Compatibility Troubleshooter?" The options I see on the Compatibility tab are things like "Run this program in compatible mode for (select an OS version)". – Twisty Sep 3 '15 at 1:21

Fixed this problem... without reinstalling windows!!!

Just go to the program folder and create new shortcuts for winword.exe, excel.exe, etc. on the desktop. Then right click on these shortcuts, view properties, and then set each of them to run as administrator (All Users -> Run as administrator).

These shortcuts will run the program without any problem. You can then use these shortcuts to replace all other existing shortcuts to those programs in your start menu and other places, although that might not even be necessary if you're lucky.

share|improve this answer
It is dangerous to mess around with permissions like that, unless you know exactly what you are doing. The administrator account is all-powerful in Windows, if something subverts any of those programs, you'd be thoroughly 0wn3d (or whatever 'leet speak is in use for that nowadays). – vonbrand Feb 4 '13 at 13:43

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .