Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to move my bash configuration from Ubuntu to Mac OS X and it looks like ls is slightly different. For instance, it won't accept the --color option.

How do I get this to work?

share|improve this question
    

6 Answers 6

up vote 40 down vote accepted

ls is actually separate from Bash. Mac OS X has a BSD version of ls, which requires -G on the command line, or CLICOLOR (and perhaps LSCOLORS) in the environment.

See man ls for more info.

share|improve this answer
3  
Ditto. I've alias ls='ls -G' set in my .bashrc on Snow Leopard. –  ayaz Sep 2 '10 at 15:40

Open the terminal window and type:

alias ls='ls -G'

Then hit Enter and done!

share|improve this answer

Use Homebrew.

brew install coreutils

Note that this will throw a prefix of g in front of all the commands (e.g., gls for ls). It gives an option to source a file that will alias these for you automatically.

I wasn't sure if there was an option to install them directly without having to do the whole alias thing, so instead in installed MacPorts and did this.

share|improve this answer

You'll need to install an alternate version of ls. The one usually used in linux is from the GNU coreutils project.

You could build and install or install from macports, fink or homebrew.

share|improve this answer
3  
That's overkill, in my opinion. You don't need to install a separate version of ls when the same feature is supported slightly differently on the existing version of ls. –  ayaz Sep 2 '10 at 15:41
    
Good point. Then again, colored ls has never been my taste. alias ls='ls -F' –  Doug Harris Sep 2 '10 at 17:37
    
alias ls='ls -FG' -- it's the best of both worlds! –  mipadi Sep 2 '10 at 17:42
    
I do this using homebrew. It's not overkill if you use both Mac and *nix computers and want your terminals to look the same -- this allows you to use the same config files across all computers. It's installed as gls and doesn't replace the original so there's really no downside. –  senderle Mar 31 '14 at 13:14

I use this Perl script I wrote on AIX. It’s useful if you’re on a system that doesn’t support --color, and also where you don’t have sudo to install packages.

Should work on Macintosh too.

share|improve this answer

compatibility for GNU and *BSD/darwin ls

~/.profile

#for *BSD/darwin
export CLICOLOR=1

ls --color=auto &> /dev/null && alias ls='ls --color=auto' ||

~/.bashrc (I don't remember if bash on Linux always reads ~/.profile, but not my zsh on ARCH)

[[ -f $HOME/.profile ]] && source $HOME/.profile
share|improve this answer
5  
Can you explain this code? –  DragonLord Feb 17 at 17:29
    
setting CLICOLOR environment variable for *BSD and Darwin systems - if it's set ls and possibly other utilities would work colored, but GNU ls (for Linux) ignores it. If "ls --color=auto" will not fail (exit status =0) - we have GNU version of ls and making alias to draw color codes in interactive mode, if it fails - then we don't need alias because of CLICOLOR variable. "&> /dev/null" just don't show stderr and stdout if something fail or if it's ok. Works for my linux and osx. (p.s. bash on osx and freebsd doesn't read .bashrc, so put it in .profile. already fixed it). –  Victor Gavro Feb 23 at 17:33

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.