Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

On my Windows 7 64-bit, Notepad++ nor its equivalent won't launch. The process and the splash appear, but beyond that it doesn't work, splash doesn't disappear.

It's been like that since I installed NP++ on a clean Windows 7. I couldn't find any similar reports from Google either.

  • Uninstall/install won't help.
  • Tried multiple versions over the few months, it's all the same.
  • When I launch it, it sits in Process Explorer, but its CPU usage stays at 0%.

Any further ideas what to try next? I fail to believe its Notepad++'s problem.

share|improve this question
I don't have a splash screen when I launch notepad++ - are you sure you've downloaded and installed the latest version from here: – Jared Harley Sep 7 '10 at 3:03
@Jared: The splash is part of PortableApps launcher, standard NP++ doesn't have it. Hangs nonetheless before showing app. Badly explained, my bad. – Tuminoid Sep 7 '10 at 3:26
I was going to ask about the splash. Are you using the ANSI or Unicode version? What is the file hash of the EXE? On my system, they're ANSI: D809BF9D4AB81F61E28E70B66640C96B, Unicode: A2635D8A9CF8FE426ABCE48BF4C89BB9. I'm also Win7 x64. (Are you x64 or IA64?) – BillP3rd Sep 7 '10 at 3:37
up vote 11 down vote accepted

Try removing any residual files that it can leave behind. I'm not familiar with the portableapps version but the normal install will store files in %appdata%\Notepad++. (You can type %appdata% in the run box to get there, if you want to go by hand it's C:\Users\username\AppData\Roaming). Delete the Notepad++ directory there and try launching it again.

share|improve this answer
Getting rid of the directory helped, it seems there was some trash from previous versions it couldn't handle. – Tuminoid Sep 16 '10 at 3:05

Some plugins have issues with NPP.

You must deactivate all plugins by moving their .dll files from folder "plugins" to "../plugins/disabled", then move them back one by one to reactivate it. After you activate one, try to launch NPP before going on.

This solved my problem. In my case, the .dll that was causing the problem was NppExternalLexers.

share|improve this answer

Removing config.xml worked for me. I had to reinstall some plugins, but it turned out to be the fastest fix.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.