Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a friend who lives in a household with three macs, one of the macs can only connect to the wireless airport network if it is completely open and visible.

Here are the obvious things I am going to check when they call me later tonight. (This is a helping out over the phone deal so I am not onsite)

  • Mac address security is not enabled
  • The password is correct
  • The security setting is the correct type of authentication (ideally WPA2, not WEP).
  • The client is not an 802.11b or g client trying to connect to an 802.11n network.

Apart from those obvious things, does anyone have any ideas ? Is there something else I am missing.

share|improve this question
    
~snip~The password is correct The security setting is the correct type of authentication (ideally WPA2, not WEP).~snip~ I'm going to guess it's one of those. –  Bryan Schuetz Aug 5 '09 at 12:20
    
And the answer was ..... incorrect password –  Bruce McLeod Aug 6 '09 at 0:38
add comment

2 Answers

If the computer has a memory of the same BSSID under different circumstances (eg. open instead of WEP) I have seen instances (rare) where the computer is unable to properly connect with the new settings (Changing Password type usually - eg. WPA2 with TKIP versus WPA2 with AES). To get around this I'd recommend trying the following:

  1. Open up System Preferences
  2. Go to the Network Preference Pane
  3. Click on Airport on the left side, then click the Advanced... button in the bottom right
  4. Under the Airport tab remove the network you are trying to connect to from the Preferred Networks section (click on it and then hit the '-' button)
  5. Then press OK, and to be on the safe side turn Airport off and then back on (Shouldn't need to be done but I found it helped)
  6. Connect to the network again.

Hope that helps, it solved issues I had with two of 10 computers I had to change when migrating from WPA2 with TKIP to WPA2 with AES.

share|improve this answer
add comment
up vote 0 down vote accepted

The user was using an incorrect password.

share|improve this answer
    
That'll do it real nicely. –  Chealion Sep 4 '09 at 22:23
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.