Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

i have SuSE10 SP2 installed. I have started the ssh daemon and iam able to login locally on the server but when i try to connect remotely using putty i get connection refused error. I have disabled the firewall on suse. and also i am able to telnet remotely some how ssh is denied.

did i miss some ssh configuration?

please help.

kind Regards jc

share|improve this question
add comment

4 Answers

up vote 1 down vote accepted

We will need more information, for example, the content of sshd_config (eg., /etc/ssh/sshd_config) file, and the state of the server IP tables ("iptables -L" ran as root or through sudo).

A couple of things that worked for me in the past:

  • Do you have a router between your computer and the server? Is it blocking port 22? Is your ISP blocking port 22?

  • Try another port by changing the Port directive in your sshd config file and restarting your sshd daemon:

    Port 2222

  • Are you using TCP wrappers (e.g., what do you see in /etc/hosts.allow)? This is independent of the firewall.

  • As a previous user mentioned, are you trying to log as root (not recommended, but then, you need "PermitRootLogin yes")?

share|improve this answer
    
I had this problem recently and I just needed to forward port 22 in the router, although if I did it again I would use a non-standard port (automated attacks started within 8 hours). @JHC Make sure root isn't allowed to ssh, or even better allow only one specific account ssh access. –  Syntax Error Sep 3 '10 at 2:26
    
thank you for your help. –  JCH Sep 3 '10 at 21:01
add comment

I also had the exact same problem. According to tcpdump the packets were arriving at the host on port 22. Put sshd server into debug mode, there were no requests being received.

Turned out to be the firewall that was blocking it. Used YaST to fix it.

share|improve this answer
add comment

If you try log in into "root" account you may need change "PermitRootLogin" option to yes (in sshd_config). Try also run ssh with debug (e.g. ssh -vvv ...) maybe there you will find some hints. Did you check system logs?

share|improve this answer
add comment

Check your firewall configuration. Your server may be blocking inbound connection attempts.

Specifically, check the configuration of iptables. Be sure it's permitting TCP connections on port 22.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.