Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am using Mac OS X 10.6.4 and Google Chrome 6.0.472.53.

I've been having an issue where I will setup the sync and everything is fine. I can click on the close button in the upper left-hand corner to close the Chrome window. When I open it later, the sync process is working.

However, when I quit Chrome and later open it, the sync process breaks. Here is the website address to a screenshot of the error:

http://davidsscreenshots.posterous.com/google-chrome-sync-error-on-mac

Has anyone else experienced this issue? I have submitted this as a bug and is recorded as issue 53118.

Any assistance is greatly appreciated. Thanks!

share|improve this question

2 Answers 2

up vote 1 down vote accepted

Perform the following steps:

  1. Stop syncing to a Google Account in Chrome through the preferences.
  2. Quit Chrome. Open Keychain Access and delete Chrome Safe Storage.
  3. Open Google Chrome. Enable syncing.

Result: Chrome no longer produces a sync error when it's restarted.

share|improve this answer
    
(Thanks for reporting back!) –  Arjan Sep 10 '10 at 21:35

I believe this to be a beta/dev version-related bug. Someone asked in that referenced bug report if you had upgraded, etc. but didn't ask if you had down-graded. When you went back to the stable channel, did you delete the Chrome plist before testing?

~/Library/Preferences/com.google.Chrome.plist

It may be that the sync portion of the plist differs between builds.

share|improve this answer
    
I had just downgraded today, but no, I did not delete that file. I will try that and let you know how it goes. Thanks for the suggestion. –  David Levine Sep 3 '10 at 0:56
    
I tried closing Chrome and deleting the file you had mentioned, but that didn't fix the issue. I thought I'd try taking it a step further and completely uninstalling Google Chrome. I dragged the Chrome icon from the Applications folder into the Trash. Then I deleted the file you mentioned. Finally, deleted the entire Chrome folder from the following location: ~/Library/Application Support/Google/Chrome After doing all that, I reinstalled Chrome. Without restoring anything, I started Chrome, setup the syncing, and quit out of it. When I started it up, the same issue occurred. –  David Levine Sep 3 '10 at 1:09
    
For testing purposes, I downloaded the latest snapshot build of Chromium. It seems to suffer from the same issue. I'm guessing this issue isn't too common because I have yet to hear from anyone else experiencing it. –  David Levine Sep 3 '10 at 1:13
    
Can you verify a few more things? 1. Do you have an active Google Docs account? 2. Which options are you syncing? Have you tried "Keep everything synced?" and have you tried it with just specific checkboxes? 3. If the two previous don't work, could you change your Google password and retry syncing? Please try all of this after deleting the aforementioned preference and support files, using the STABLE build. –  pattern86 Sep 3 '10 at 3:35
    
Initially, I was only syncing bookmarks. So I completely uninstalled Chrome again and deleted all of the aforementioned files. I then reinstalled Chrome, enabled sync, and chose to sync everything. Then I restarted Chrome and the same issue occurred. One thing I noticed is that Chrome synced my bookmarks and preferences, but not my extensions. Then I reset my password and tried the syncing again. After restarting, the same error occurred. On my Chrome issue post, they asked me to "start Chrome with the --user-data-dir=<give_name_of_local_directory> and try syncing?" Not sure what that means. –  David Levine Sep 3 '10 at 17:07

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.