Sign up ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

This is weird. I can't even access, it simply says "Internet explorer cannot display this webpage", as if it couldn't locate it. Yet, I get to it just fine in chrome.

I have even gone to Internet settings -> reset to reset all of my options - no go. I have tried lowering my security settings to the bare minimum. Yes, I have the SSL and TLS options checked under Security. I'm out of ideas. Anyone?

I'm on Windows 7.

share|improve this question
A long shot, but does turning of your firewall (if any) help? – Vervious Sep 3 '10 at 0:38
Can Firefox, Chrome, or Opera access any HTTPS sites? – Stephen Jennings Sep 3 '10 at 3:41

3 Answers 3

I know it sounds silly, but make sure your Date/Time settings are correct, I have seen this issue caused multiple times simply from a wrong time.

share|improve this answer

The only solution I have found [source: Cannot Access Secure HTTP Sites? ]

1) Open START > and run > CMD . insert & execute this command (or one by one, but remove &&):

regsvr32 urlmon.dll && regsvr32 wintrust.dll && regsvr32 initpki.dll && regsvr32 dssenh.dll && regsvr32 rsaenh.dll && regsvr32 gpkcsp.dll && regsvr32 sccbase.dll && regsvr32 slbcsp.dll && regsvr32 cryptdlg.dll && regsvr32 shdocvw.dll && regsvr32 mshtml.dll && regsvr32 browseui.dll && regsvr32 jscript.dll && regsvr32 vbscript.dll && regsvr32 oleaut32.dll && regsvr32 softpub.dll && regsvr32 urlmon.dll && regsvr32 actxprxy.dll

(p.s. To paste inside CMD, right click> PASTE)

2) Then open INTERNET EXPLORER > Tool> Internet Option> AND

---a) in Security Tab> choose trusted Sites and then click on default level. Then click SITES and add there your sites.
---b) in Content Tab > click on Clear SSL State You will get a message that the SSL cache was cleared Successfully, click on OK
---c) in Advanced Tab > check USE SSL3.0 and SSL 2.0 (in some cases, before that, you may need click "RESET DEFAULTS+RESET", and do all the above steps again..)

3) Check your COMPUTER DATES (year,month,day), it needs to be correct.

p.s. Problems solved:

Unable to view & open https secure website, they not opening, nor loading..; Internet Explorer Cannot Connect to Secure Sites; Https Sites Not Working Ie9; Can't  browse or Access Secure(for example Bank) websites; I cannot log in to or connect... these might happen after upgrading.
share|improve this answer
Although this may answer the question, you should give a more detailed description of the linked content and explain how it relates to the question. This will help ensure that this answer remains useful in the event the linked page goes is removed or goes offline. For more information, see this Meta Stack Exchange post. – bwDraco May 5 at 17:16

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.