Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to use Git at work on Windows using msysgit (though Cygwin), but we are stuck with a central CVS repository. So what I have done is made my CVS working folder a Git repository as well. So far so good.

The problem comes in when I switch branches in Git. Somehow CVS thinks that files changed, but Git says there are no modifications.

To be more precise consider the following scenarios, please:

1:

cvs co .
git add .
git commit -m "auto"

Checking changed files in CVS and Git both report no changes.

2: now do:

git co someBranch
git co master (back to files identical to scenario 1)

Checking changes files in CVS reveals that files that had no modifications in scenario 1 are considered modified or even newly created (I think I saw some newly created ones).

I'm starting to think this is related to the timestamps on files not being preserved with Git properly or some quirk of CVS. It might also be Git not preserving newlines, although I have also tried this by setting a property on Git to keep the newlines and not replace them.

Any help, tests, suggestions are much appreciated.

share|improve this question

1 Answer 1

This answer from Stack Overflow has a very detailed description of how to use git & cvs together. A different SO question about best practices for using both has a few other answers.

share|improve this answer
    
Thanks, though i have already read that and the problem is i don't have cvsimport in msysgit. It didn't come with it. So that's not an option. –  Coder Sep 3 '10 at 11:42
    
Also, i would be happy with the simpler approach i mentioned above, but given that this does not work really concerns me. I mean what i'm trying to do is the simplest setup for using cvs and git and it's not working. –  Coder Sep 3 '10 at 11:44
    
wait, what do you mean by "msysgit through cygwin"? msysgit doesn't depend on cygwin. have you tried using cygwin+git? do you still have the same issues? –  Velociraptors Sep 4 '10 at 1:27

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.