Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have few DVD-RAM disks and when using udftools, specifically

sudo mkudffs --media-type=dvdram /dev/sr0

where /dev/sr0 is my DVD-RAM drive, I get trying to change type of multiple extents and nothing happens.

What should I do?

EDIT

After trying with dvd+tools, here's what I got:

#dvd+rw-format /dev/dvd -format=full -ssa=default
* BD/DVD±RW/-RAM format utility by <appro@fy.chalmers.se>, version 7.1.
* 4.6GB DVD-RAM media detected.
* formatting 54.8|

And same error as before from mkudffs.

share|improve this question

How to format a DVD with UDF

mkudffs /dev/dvd

If that fails with a trying to change type of multiple extents error, then it's likely that you've got a virgin disk. If you have the dvd+rw-tools package, you can re-format it with the following command:

dvd+rw-format /dev/dvd

Then run the mkudffs command again.

Source of above info

share|improve this answer
    
/dev/dvd is a link to /dev/sr0 and it too fails. I'll try with dvd+rw-format. – AndrejaKo Sep 3 '10 at 15:45
    
Format just finished and I'm still getting same error. – AndrejaKo Sep 3 '10 at 16:22
    
As a sidenote, I just tried mkudffs on a known working CD-RW and I got same error. – AndrejaKo Sep 3 '10 at 17:00
    
After several dvd+rw-format /dev/dvd I noticed that it exits before 100%. Every time it completes a few percent more and I'm at 97.9% now. – AndrejaKo Sep 3 '10 at 19:13
    
@AndrejaKo - Seems your problem lies somewhere else. I'll convert this answer to community wiki in case it helps someone else. – Nifle Sep 3 '10 at 22:14

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .