Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I discovered that when I do ssh to a machine using OS X 10.6 and use mc I do not see the graphical line drawing characters.

This does not happen if I open terminal and start mc.

I'm connecting using putty configured to use xterm-color, configuraton that works just fine if I do ssh to a linux machine.

The mc from OS X is version 4.7.0 (installed using macports).

What locale returns:

  • LC_CTYPE="C" <== ssh
  • LC_CTYPE="UTF-8" <== Terminal.app

ssh: mc > display bits shows: 7-bit ASCII (changing does not help, it defaults to the same value) Terminal.app: mc > display bits shows: UTF-8

The environment shows TERM=xterm-color in both cases Terminal.app and ss but mc looks different.

I filed a bug to mc with this information at http://www.midnight-commander.org/ticket/2339

share|improve this question
    
On my OS X mc never shows the graphical line drawing characters. –  Mike L. Sep 3 '10 at 12:20

2 Answers 2

The following option for mc did the trick for me.

./configure --with-screen=ncurses

I also had other options but I think those are irrelevant

--enable-extcharset --enable-charset --with-edit

I was accessing osx from Ubuntu. Here is locale output on osx:

LANG=
LC_COLLATE="C"
LC_CTYPE="C"
LC_MESSAGES="C"
LC_MONETARY="C"
LC_NUMERIC="C"
LC_TIME="C"
LC_ALL=

And I got xterm-256color as my TERM.

share|improve this answer

Good luck!

You might have luck changing fonts, linedrawing mode and translation settings on PuTTY.

Using Courier New or Lucida Console can give you linedrawing characters, using the Unicode linedrawing points option.

You might also want to try Windows' Terminal font.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.