Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Visual Studio 2010 is driving me mad, mainly because it insists on scrolling context menus even when there is more than enough room to show all of it. It is particularly bad in the solution explorer when the file you right-click is half way down the screen.

I have even customized the menu to remove infrequently used items but it still happens a lot.

One option might be to reduce the font size on context menus since it is quite big. The only way I can think of doing this in Windows 7 would involve switching to a Windows Basic theme and setting the font size for all menus but I don't want to do this. Ideally I just want the menus in VS to be smaller and I still want to be able to use Aero.

Does anyone have any ideas?

[Edited title to make question clearer]

share|improve this question

1 Answer 1

up vote 1 down vote accepted

From Question: Can I turn off context menu scrolling in VS2010?:

This is a bug. It's been reported several times on Connect:

Please avoid scrolling context menus when vertical space is available
Context menus open in scrolling mode while there is place to show the whole menu
Incorrect project contextmenu height

... but Microsoft doesn't seem keen to fix it.

The best you can do is to vote for re-open. Maybe they'll fix it in Service Pack 1.

EDIT: A fix is now available from Microsoft:

KB2345133 - Fix for scrolling unnecessarily in VS context menus
KB2413613 - QFE: WPF context menu is clipped when using multiple monitors

share|improve this answer
    
I had already seen some bug reports about this problem but I was hoping there was some way of preventing it from being such a problem, perhaps by reducing the height of menus. I have updated my question to make this clearer. –  James Sep 3 '10 at 12:38
    
@James: I don't have VS2010, but VS always had detailed options for setting the fonts. Can you find something for context menus? However, if this is a hard bug, it might happen no matter which font. I would also suggest to read the above threads - they might contain useful ideas. –  harrymc Sep 3 '10 at 12:57
    
I had a look at those Connect forum threads but I didn't find any good workarounds unfortunately. I searched the Visual Studio options for anything that sounded promising but could not find any options relating to menu fonts. In many ways VS2010 seems like a step backwards :-( –  James Sep 3 '10 at 13:13
    
@James: I agree - I uninstalled VS2010 within a few hours and went back to VS2008. One of the reasons was the very slow load - this problem that existed in VS2003 and was resolved in VS2008 has come back. By uninstalled I mean re-imaged my system disk, since VS is notoriously hard to uninstall. –  harrymc Sep 3 '10 at 13:39
    
@James: A fix is now available from Microsoft. –  harrymc Oct 20 '10 at 7:34

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.