Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have an Excel spreadsheet with several connections, that are set to refresh automatically (Refresh Data when opening the file).

I think there is a problem with one of the queries because it hangs upon opening and I can't even see what it is trying to execute.

Is there a way to open the file w/o the auto-refresh?

share|improve this question
What version of Excel? – JNK Sep 3 '10 at 13:51
@JNK: the file itself is .xls, I think it's in 2003 format. I'm using 2007 to open it. – Meringros Sep 3 '10 at 13:55
up vote 2 down vote accepted

In Excel 2007, you should do the following:

In Excel Options, navigate to Trust Center > Trust Center Settings > External Content. You'll see the Security Settings for Data Connections and Workbook Links. Disable both.

Additionally, navigate to Formulas tab, click Manual under Calculation options, and then click OK. Restart Excel and you're done.

In Office 2010, go to the same External Content menu, and select Disable all Data Connections as well as Disable automatic update of workbook links.

share|improve this answer
Thank you Mehper, it worked. – Meringros Sep 4 '10 at 3:23
You're welcome. – Mehper C. Palavuzlar Sep 4 '10 at 9:34

You can also open the workbook in Protected View. In the open file dialog box, you can click on the down triangle next to the word "Open" and select "Open in Protected View".


share|improve this answer
I don’t see that in my Microsoft Excel 2007 (on Windows XP). What version of Excel are you using? – Scott Jun 21 '13 at 16:59
i see it in 2010. it's in the open dialog. Select a file, then before you click open notice the small triangle on the button indicating its a drop down. click on that instead, then select one of the options. – FistOfFury Aug 26 '14 at 19:37

OK, in Excel 2007, go to excel options:

Office Button -> Excel Options at the very bottom.

At the bottom of the Advanced options, check "Ask to update Automatic Links

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .