Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Possible Duplicate:
Why won't vsftpd let me log in with a virtual user account?

I'm trying to configure virtual FTP users along with real users on a server. I installed VSFTP and it works fine. I tried to follow this tutorial: http://howto.gumph.org/content/setup-virtual-users-and-directories-in-vsftpd/

However, when I try to login via FTP, the login fails. I solved the problem by creating a real user on the machine called "jjames", but I would like it to work without the real user.

My .htaccess file is in /etc/vsftpd/passwd, I tried creating it with and without the -m flag with the virtual user jjames.

This is my configuration information...

grep -vE "^#" /etc/vsftpd/*

/etc/vsftpd/chroot_list:jjames
/etc/vsftpd/ftpusers:root
/etc/vsftpd/ftpusers:bin
/etc/vsftpd/ftpusers:daemon
/etc/vsftpd/ftpusers:adm
/etc/vsftpd/ftpusers:lp
/etc/vsftpd/ftpusers:sync
/etc/vsftpd/ftpusers:shutdown
/etc/vsftpd/ftpusers:halt
/etc/vsftpd/ftpusers:mail
/etc/vsftpd/ftpusers:news
/etc/vsftpd/ftpusers:uucp
/etc/vsftpd/ftpusers:operator
/etc/vsftpd/ftpusers:games
/etc/vsftpd/ftpusers:nobody
/etc/vsftpd/passwd:jjames:$apr1$x9eqi...$FprvWontP8bZLSrwFTBL4/
/etc/vsftpd/user_list:root
/etc/vsftpd/user_list:bin
/etc/vsftpd/user_list:daemon
/etc/vsftpd/user_list:adm
/etc/vsftpd/user_list:lp
/etc/vsftpd/user_list:sync
/etc/vsftpd/user_list:shutdown
/etc/vsftpd/user_list:halt
/etc/vsftpd/user_list:mail
/etc/vsftpd/user_list:news
/etc/vsftpd/user_list:uucp
/etc/vsftpd/user_list:operator
/etc/vsftpd/user_list:games
/etc/vsftpd/user_list:nobody
/etc/vsftpd/vsftpd.conf:anonymous_enable=NO
/etc/vsftpd/vsftpd.conf:local_enable=YES
/etc/vsftpd/vsftpd.conf:write_enable=YES
/etc/vsftpd/vsftpd.conf:local_umask=022
/etc/vsftpd/vsftpd.conf:dirmessage_enable=YES
/etc/vsftpd/vsftpd.conf:xferlog_enable=YES
/etc/vsftpd/vsftpd.conf:connect_from_port_20=YES
/etc/vsftpd/vsftpd.conf:xferlog_std_format=YES
/etc/vsftpd/vsftpd.conf:chroot_list_enable=YES
/etc/vsftpd/vsftpd.conf:chroot_list_file=/etc/vsftpd/chroot_list
/etc/vsftpd/vsftpd.conf:user_sub_token=$USER
/etc/vsftpd/vsftpd.conf:local_root=/var/www/html/bridaluxe.com/$USER
/etc/vsftpd/vsftpd.conf:listen=YES
/etc/vsftpd/vsftpd.conf:
/etc/vsftpd/vsftpd.conf:pam_service_name=vsftpd
/etc/vsftpd/vsftpd.conf:userlist_enable=YES
/etc/vsftpd/vsftpd.conf:tcp_wrappers=YES

This is my PAM file... (Note: I'm not sure if PAM is even working, I did "yum install pam")

#%PAM-1.0
session    optional     pam_keyinit.so    force revoke
auth       required     pam_listfile.so item=user sense=deny file=/etc/vsftpd/ftpusers onerr=succeed
auth       required     pam_shells.so
auth       include      system-auth
account    include      system-auth
session    include      system-auth
session    required     pam_loginuid.so

# Customized login using htpasswd file
auth    required pam_pwdfile.so pwdfile /etc/vsftpd/passwd
account required pam_permit.so
share|improve this question

marked as duplicate by nhinkle Mar 7 '12 at 23:27

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

2 Answers 2

I think you can refer to the vsftpd example which is included in the package "vsftpd".

It would be located in the directory:

/usr/share/doc/vsftpd-$VERSION/EXAMPLE/VIRTUAL_USERS
share|improve this answer

Use below to configure.

http://en.gentoo-wiki.com/wiki/Vsftpd#b.29_pam_pwdfile

I have tried this on my setup & it is working as expected.

share|improve this answer
    
Welcome to Super User, and thanks for helping out by providing an answer! In the future, if you find two questions which are nearly identical, please flag them for moderator attention and mark them as a duplicate, instead of posting the same answer twice. This helps us to keep things in order and consolidate information. –  nhinkle Mar 7 '12 at 23:28
    
Thanks for the info. I am very new & was not aware of this, Will keep this in mind. –  atolani Mar 8 '12 at 22:49

Not the answer you're looking for? Browse other questions tagged or ask your own question.