Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Can someone help me connect to internet via ethernet in backtrack 4 final?

share|improve this question

4 Answers 4

up vote 1 down vote accepted

You're probably not getting an IP assigned automatically. Try running:

ifconfig eth0

and see if you have an address assigned to that interface. It should say something similar to

inet addr:192.168.1.23

if it doesn't then you should run:

ifconfig eth0 192.168.1.23

to set it manually.

Note: I've assumed your network is 192.168.1.0 and that the IP 192.168.1.20 is available. You should probably change that to suit your needs.

share|improve this answer
    
see Eric J's post... –  studiohack Apr 6 '11 at 18:38

Internet usually works in Back Track 4 for me without problems.

What you have to remember is that this will change from machine to machine, it is most likely that Back Track simply does not have the correct drivers for your wired or wireless connection by default.

I would take a look at the forums and try to ask for help on adding a driver.

Alternatively, it could be something as simple as the network you are connecting to does not support DHCP and you simply need to manually assign an address.

Without knowing your machine, I can't really advise further.

share|improve this answer
    
do you have to do anything for it? or does it just work? –  user38008 Sep 3 '10 at 21:59
    
@user38008 Depends where I am connecting from. It does not have my wireless drivers built in, but when I run it through RJ45, it works fine out the box if there is DHCP.... I also carry a wireless USB stick which it does have the drivers for. –  William Hilsum Sep 3 '10 at 22:34

The easiest method to getting connected is just to run the the DHCP client.

$ dhclient

It will simply find and ask the DHCP server on your network for an available IP address. It will assign you an IP and add the appropriate routes to the routing table for you as well. It will also configure your setting to add the appropriate DNS that has been specified for your network.

@kirbuchi's post: This is a start, but it won't completely work, because it is still missing the other half. You can give it an IP address, but likely when you try to connect to a remote it will give a time exceeded message. This is simply because the routing table is still incomplete and it does not know where to send traffic anywhere else other than to an IP address on the local network, given that you know the IP address at all. If you want to use the computer's hostname, well you're out of luck on that, too. You haven't specified what/where your DNS is yet either. For the easiest method, please look at my answer post for this solution probably will not work.

share|improve this answer

I'm assuming that your Ethernet cards device name is eth0 an you have a dhcp enabled router/server

First you need to start networking

/etc/init.d/networking start 

Then you need to get an ip address

dhclient eth0

If that suceeds you should be able to browse the net.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.