Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

How do I keep firefox from using drop-shadows on unselected tabs? Once I started using personas, the inactive tabs all have shadows under their text that reduce their readability.

share|improve this question

3 Answers 3

up vote 1 down vote accepted

I noticed this while using the Tree Style Tab add-on with Firefox 4, and solved it by adding the following to my userChrome.css file:

.tabbrowser-tab { text-shadow: none !important; }

This file is located in the chrome/ folder of your profile. If one doesn't already exist, you'll want to copy the corresponding example file and edit it accordingly.

Not sure if that style is specific to Tree Style Tab, or a generic XUL style used by Firefox, but it's worth a shot.

share|improve this answer
    
I will try this once I upgrade to firefox 4. –  K Robinson Mar 27 '11 at 1:47
.tabbrowser-tab { text-shadow: none !important; }

This works perfectly to disable all text shadows in FF4 and FF5

share|improve this answer

Quick tip/guide to readers of the answer, like me.

You must create the userChrome.css inside your profile folder.

Operating system                    Profile folder location(s)
Windows NT (NT4.x/2000/XP/Vista/7)  "%APPDATA%\Mozilla\Profiles\XXXXXX.Default\"
Unix/Linux                          ~/.mozilla/
Mac OS X                            ~/Library/Mozilla/ -- ~/Library/Application Support/
  • Under Windows press Windows Key + R → Type in %APPDATA% → Click OK
  • Create a folder "chrome" inside your profile folder;
  • Create the nonexistent userChrome.css with the CSS string suggested;
  • Restart your browser.
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.