Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

In my Firefox (linux) I can change the page as A4 in File → Page Setup → Page Size. Doing this, I inform the browser to print my pages as A4, instead of the default of Letter. My printer doesn't have Letter paper size (it just exists in USA). If it forget to change the page size, I have to walk to it, press "change page size" to start printing it.

How do I set the default page size to A4 once and forever?

share|improve this question
1  
The solutions presented here do no work for me on Firefox 17 on Ubuntu Precise. Could you please update your question to trigger new answers? –  JJD Dec 17 '12 at 22:04

7 Answers 7

up vote 5 down vote accepted

I had this same issue today and found this post after searching Google. I fixed it in basically the same way as Android Eve laid out, just using the print.print_paper_name setting instead and using iso_a4 as the value.

So the long version, that's:

  1. In the address bar, type about:config.
  2. Enter print.print_paper_name in the filter box and press Enter.
  3. Double-click the entry named print.print_paper_name.
  4. Enter iso_a4 in the dialog box and press OK.
  5. Notice that it now works fine, and upvote this response ;)
share|improve this answer
    
It works on Ubuntu 14.04. Huge fault on the side of ubuntu (et al) to not set Letter/Paper Size to Locale. Here in Europe we don't have US paper. In the US you have US paper. If I wanted to print with US paper I would have set my Linux locale to US or move to the US altogether and buy my paper there. –  Achmed Durangi Jun 3 at 18:08

Make sure /etc/papersize has a4 in it, for some reason it tend to be letter.

sudo echo a4 > /etc/papersize 

Then set LC_PAPER to your locale, in my case it sweden.

echo 'export LC_PAPER="sv_SE.utf8"'>> .profile 

All locales but en_US should work since US is the only one that uses letter, the rest of the world uses A4.

share|improve this answer

Check out this man page:

paperconfig - configure the system default paper size

Synopsis

paperconfig [ -v,--version ] [ -h,--help ] [ -p, --paper papername | --force ]

Description

paperconfig sets the system (or default) paper to be used by tools using the papersize >file. It can either ask interactively for the paper to use or be called non-interactively >by scripts.

When the paper size has been changed, paperconfig notifies other packages of the change >by running the scripts in the /etc/libpaper.d directory.

Options

-v,--version
Print the version of paperconfig and exit.
-h,--help
Print help about usage and exit.
-p, --paper papername
Use papername if possible. If papername is not a valid paper, print an error message and exit.
--force
Force interactive selection of the system paper even if the actual paper is a valid one.

Environment

PAPERCONF Full path to a file containing the paper size to use; this file will be rewritten with the system paper size.

Files

/etc/papersize
Contains the name of the system-wide default paper size to be used if the PAPERSIZE variable is not set.

/etc/libpaper.d
Directory of scripts to run after the paper size has been changed. This package puts no scripts here, but other packages may.

So you would run paperconfig -p a4 in the commandline.

share|improve this answer
    
I don't have paperconfig in my old CentOs 5.2 (it is a corporate machine) –  neves Sep 3 '10 at 21:51
    
If there's a /etc/papersize file in your computer, you can change the contents to a4 and it'll have the same effect. –  digitxp Sep 3 '10 at 22:06
    
no file either. Thanks anyway. –  neves Sep 6 '10 at 16:29
2  
Thanks for that from me as well - unfortunately, I just checked /etc/papersize - and it says a4 there; however, firefox still insist on letter (damn it...) –  sdaau Jun 13 '12 at 8:48
    
Agree with sdaau FFox does seem to ignore /etc/papersize. Time will tell whatother programs do ignore that setting too. It's times like these that makes it totally obvious why everybody uses Windows and Mac. It's completely inferable that nobody in his right mind would want to fiddle around with endless text files if the only thing he wants to do is to print with his printer that he bought in a country where there is no us_letterhead available anywhere, countrywide. –  Achmed Durangi Jun 3 at 18:10

Dave's answer didn't work for me in Firefox 5 on Linux, it seems Firefox now stores separate settings for each printer it sees. If you search for print_paper_name in about:config you will see several similar settings for each printer e.g. "printer.printer_Samsung_ML-2010.print_paper_name". Set all of them to iso_a4 and join the civilised world of standardised paper sizes.

share|improve this answer
    
Many thanks, @LukeMcCarthy - that seems to have done the trick for me; indeed there were a ton of options that I saw on my Firefox, were set to na_letter; changed those to iso_a4. and even without a restart, the default page size changed (for the printer I wanted to use, which for me was printer_PDF.print_paper_name). Thanks again - cheers! –  sdaau Jun 13 '12 at 8:53
    
.... however, the crappiest part about it is that now I get A4 selected by default in the "Print to File" options - but that STILL does not SET the goddamn page size; so now I have go back through that options window, and RECLICK page size to something OTHER than A4, and then BACK AGAIN to A4, so it understands it is goddamn A4 (always use pdfinfo on those printouts).... Goddamn it! –  sdaau Jun 13 '12 at 9:07
  1. In the address bar, type "about:config".
  2. Enter "print.postscript.paper_size" in the filter box and press Enter.
  3. Double-click the entry named "print.postscript.paper_size".
  4. Enter "paper" in the dialog box and press OK.
share|improve this answer
    
I've already had made this configuration, but Firefox insists to send Letter pages :-( –  neves Sep 3 '10 at 21:49
    
On Windows, Firefox doesn't even have a paper size option and just follows the default setting provided by the printer driver. Maybe you have to change the paper tray settings through your printer driver's interface. Not sure if there's a centralized place to do this on Linux... If you're using Gnome, maybe you can try System -> Administration -> Printing –  billc.cn Aug 9 '11 at 0:36

Try going to Page Setup and disabling the Shrink to fit Page Width option. This was the only thing that worked for me after changing the config options didn’t. (For changing from default paper size 'Letter' to 'A4'.)

share|improve this answer

Enter print in the filter box and press Enter, sort by value and change all na_letter to iso_a4, press OK

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.