Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm running VMWare Fusion on Mac OS X (Snow Leopard) with a Windows 7 guest OS. They are networked using a bridge.

I'm running a couple of local development web servers on Mac OS X and I want to access them from Windows for testing.

The IP address of the host OS is 192.168.0.2. I can ping this IP address from the guest. If I enable the Mac OS X web sharing I can see the example site from the guest.

I can't access my local servers on ports 2060 or 8000. Both the Windows and Mac OS X firewalls are off.

(i.e. http://192.168.0.2/ works but http://192.168.0.2:2060 doesn't - I've tried with both Firefox and IE.)

share|improve this question
    
Are the development servers definitely bound to *:2060 and *:8000, or just 127.0.0.1:2060 & 127.0.0.1:8000? It sounds like you have no resolution/communication problem between the two hosts. I'd point the finger at the dev servers themselves since you stated you have no firewalls. – Mark Embling Sep 4 '10 at 12:51
    
Ah, that sounds like it could well be the problem. Dammit - thanks. One is the Django devserver (so I guess I can fix that myself) the other is a server specifically for Silverlight projects (called Chiron) that may not be so easy to fix. I'll probably have to setup another server for it. – fuzzyman Sep 4 '10 at 13:15
    
I've had better luck with this sort of question on ServerFault.com. – Daryl Spitzer Sep 7 '10 at 14:49

This is one of the first search results on google but I noticed there were no answers. Hope my answer might help someone in the future:

For me, my solution was running my webserver (in my case, Jboss) to be accessible through IP address. I just needed to add a parameter for when starting up my webserver on the host OS:

. run.sh

vs

. run.sh -b 0.0.0.0

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .