Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

On my physical laptop I have Windows 7 installed along with VMWare 7. Now I create a virtual machine and installed Linux Mint 9 on it and everything works on the virtual machine.

When I try to access the internet from inside my VM I don't have any connection except one called: "auto eth0" listed as an available connection.

When I try to click that connection the 'connecting' animation runs, but nothing else happens.

What can I do thanks.

Picture of Adapter settings. alt text

share|improve this question
    
You may have your firewall on. Turn it off and give it a try. –  user206509 Mar 12 '13 at 18:03
add comment

3 Answers

up vote 4 down vote accepted

Network Adapter Properties

If you have multiple network adapters (including both virtual and hardware) installed, go to each one and make sure that "VMware Bridge Protocol" is only checked on the adapter you actually connect to the internet with. In my case, I have some virtual adapters installed by VMware, my bluetooth radio, and an extra wifi adapter installed by my wireless drivers (for connection sharing). VMware will by default install this Bridge protocol on all adapters it did not install itself, and even if you only use one network adapter, there might be extra virtual ones confusing VMware.

share|improve this answer
add comment

I agree with both the answers above, but here is the difference. If you are using DHCP to obtain IP addresses, depending on whether you have the VM network adapter settings set to NAT or Bridged, you will obtain IP addresses on a different subnet. If bridged you will obtain IP addresses from the DHCP server on the local LAN, this essentially connects you directly to the external network. This meaning that if the PC you are using to run the virtual host has a subnet of 192.168.1.x, then your VM(s) are going to obtain an IP address on the same subnet. Therefore your VM's are connected directly to every other PC/device on the local LAN. If you have the settings for the VM set to NAT, you will receive an IP address from the virtual DHCP server which is set to defaults of 192.168.83.128-254. This can be modified if need be, but a different subnet from the local LAN will separate you from all the LAN devices. If you are using NAT then you do not need to enable the VMware Bridge protocol. Hence you're not using it. Make sure in your web browser you make the necessary changes, so it automatically detects the LAN settings. Make sure if you want the VM's to be able to connect with each other that they both are configured the same way. You can also hard-code the IP addresses if not using DHCP. If this doesn't help please reply back.

share|improve this answer
add comment
  1. Is the virtual network adapter that is added connecting/mapping to the physical network having the connection to the internet (you may have multiple physical networks)

  2. Make sure that the virtual network adapter is connected in bridged or NAT.

  3. Make sure you do not need any special drivers for the operating system to discover the internet. (USB driver/Wifi driver or software)

share|improve this answer
    
Please check screenshot I posted. So far none of these suggestions worked. Thanks. –  Sergio Tapia Sep 4 '10 at 16:03
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.