Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to set up SSH so I went into my firewall (Firestarter) and started going through the settings. Afterwards, nothing worked and everything was getting blocked by the firewall. The only way I can find to fix it is by disabling it, which is okay at home, but when I go to a library or coffee shop, that's a humongous no-no.

How can I reset it?

And while I'm at it, what am I supposed to do to open the right ports for SSH?

share|improve this question

1 Answer 1

up vote 2 down vote accepted

Using firestarter, I like to have all ports that I don't need closed... If you go to the tab "Policy" and select "Outgoing traffic Policy", two radio buttoned options appear. Set this to "Allow, block specific traffic". Now head back to the "Policy for incoming traffic". There should be no rules defined there. If you right-click one of the empty areas, you'll be able to specify rules for traffic allowance. If you right-click and add through the upper area you'll be able to allow entire hosts access to all ports. If you use the lower area, you'll be able to create rules per port. These are the settings I usually use:

Allowed services (lower area):

  • SSH (port 22)
  • Samba (port 137-139 445)

Ports are automatically selected when selecting the name of the service in the "Add new rule" window.

If you find anything blocked, check the "Events/log" tab and see which service/port is being blocked. (You might need to refresh by clicking the blue rounded arrow at the top) Then add a new rule for that service/port.

P.S. I'd post screenshots but I'm afraid they'd all be in Dutch. Let me know if you need help finding things!

share|improve this answer
    
Thanks for the answer. Do I set the policy to be for everyone? Or just my IP? –  digitxp Sep 4 '10 at 22:48
    
@digitxp Whatever you feel safest with! I keep all outgoing traffic open and all incoming traffic closed. All incoming exception ports are available for everyone. –  BloodPhilia Sep 4 '10 at 22:53
    
Darnit, my firewall seems to have gone zonkers and now won't even let me ping a website when I turn it off. Am I missing anything? –  digitxp Sep 4 '10 at 23:54

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.