Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have 3 machines. Two of them running Windows 7 Ultimate 64-bit, let's call them Windows 7-one and Windows 7-two. One is running Windows XP SP3, let's call that one Windows XP-one.

I've shared some folders on one of the Windows 7 machine (Windows 7-one). The XP machine (Windows XP-one) has no problems connecting to the machine and I can view and access the shared folders.

Just doing start->run, typing \Windows 7-one, a window pops up, showing the shared folders, just as expected.

The other Windows 7 machine (Windows 7-two) on the other hand, not so much. If I try to open \Windows 7-one I get a prompt for a username/password with an error message at the bottom saying "Logon failure: unknown user name or bad password".

Why? I thought I had enabled anonymous access?

What I've done: Enabled the guest account, shared the folder, giving "everyone" full-control permissions, enabled everything under the advanced sharing options, etc. etc. etc.

The only thing I've not done is restarted Windows 7-one, perhaps that'll work ....

Any ideas?

EDIT Just figured out one thing that might have something to do with this. All three machines have a user account with the same username. On Windows 7-one and Windows XP-one, it's got a blank password. The account on the Windows 7-two machine is password protected. Should that matter at all? I cannot see why it should.

share|improve this question
1  
I noticed that the double backslashes in front of the computer names have been changed to a single backslash. Please ignore that :-) –  HaukurHaf Sep 5 '10 at 0:40

6 Answers 6

One thing that Windows 7 has is Credential Manager. This stored previously used credentials to avoid asking for login credentials all the time. Nifty! However, if the credentials change, it doesn't prompt again. To view the credentials, go to:

Control Panel → Credential Manager

Poke around and find the credentials you're looking for. You can delete them, then try to reconnect. It should ask you again. You can type in the necessary credentials.

It might also be an issue with your login domain. When typing in a username, use:

[machine-name]\\[username]

Using machine name specifies which machine the credentials are on.

share|improve this answer

OK, one thing I discovered.

I noticed that the the login prompt that I got stated that it was trying to use a domain for logging in, the domain being the current computer (win7-two). I clicked "another user" and typed in the full name of the user on the other machine (\win7-one\username and a blank pwd) and that worked!

Still puzzled why it insists on using the current computer as a domain, the XP machine did not do that. This doesn't really solve my problem since I'll always have to go through this user/pwd prompt.

I guess I'll just map this as a network drive and having it remember my credentials. That will work for me for now.

Still would be nice If anyone knows why this behaves differently between two win 7 machines as opposed to win7 - winxp.

share|improve this answer
1  
You probably should be taking those Win7 machines out of a domain and putting them in a workgroup. To check if it really is in a domain, right click "Computer", select Properties, and look in the middle section "Computer name, domain and workgroup settings". It will tell you there the workgroup or domain name. If in a workgroup, leave it alone. If in a domain, click the Change Settings button to change it. Make sure all your machines in the same named workgroup. –  quickly_now Nov 28 '10 at 8:01

In a Workgroup, if the same username/password combination exists on all of the computers, no password prompt will appear.

For instance, at home, I put the username "mike" and the password "password" into all three of our computers. I put the username "allison" and the password "password" into all three computers.

share|improve this answer

File sharing may not work with blank password. You might want to add password to all your machines.

share|improve this answer

If you have the 'User Logon failure' problem, try this in your XP machine:

  1. Open Control Panel > Administrative Tools > Local Security Policies
  2. Go to Local Policies > User Rights Assignment
  3. Search for 'Deny access to this computer from the network'
  4. Remove 'Guest' account from the list
share|improve this answer

You could always try setting up a HomeGroup between Windows 7 machines...unfortunately, this will not work for Windows XP...

How to set up a HomeGroup: http://windows.microsoft.com/en-us/windows7/help/home-sweet-homegroup-networking-the-easy-way

Hope that helps...

share|improve this answer
    
Hi, thanks for the comment. I did think about setting up a homegroup, but it does not really solve my problem :-) –  HaukurHaf Sep 5 '10 at 0:50

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.