Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I cannot connect to the Internet using the onboard Ethernet, unless I plug in an additional PCI LAN card. The onboard Ethernet controller connects to the Internet fine with this extra LAN card plugged in.

The extra card is disabled so I can't see why it would make a difference to my onboard card. But the second I remove the extra card, my onboard Ethernet controller fails to detect the IP address.

This only occurs when running Windows XP; in Windows Vista all is fine without the extra PCI card.

I have already been on the Acer website and installed the latest Windows XP drivers, but it has made no difference. I need that PCI port for something else. Any solutions?

(Acer M1610 with XP Pro 32; it was shipped with Vista but due to RAM issues, I decided to finally downgrade it to Windows XP.)

Edit: Okay I have a fix, but the only way to get it working is to set the adapter to 10 Mbps Full Duplex. (Defaults to an auto select) I have the option for 100 Mbps Full Duplex but that doesn't work. (Is this a driver issue?) I need to be able to have it on automatic/100 Mbs because I have a 20 Mbs downstream on my Internet connection.

share|improve this question
1  
Just to clarify: did the onboard ethernet work properly (without the PCI card) with Vista? –  Velociraptors Sep 7 '10 at 20:04
    
Yes it did, it wasn't until I installed xp that there was a problem, I downloaded the latest drivers and they wouldn't update because it has the latest drivers. –  Arch Angel Sep 8 '10 at 5:32
    
I am totally not an expert, but could this be a 32/64 bit issue? Maybe Vista was running 64 bit, and maybe the onboard card doesn't have good 32 bit drivers? Please ignore me if you want ;-) -- I'm really just guessing! –  Arjan Sep 12 '10 at 9:19
    
If you read my edit i have it working, just at half speed which is no good. No vista was definitely 32bit the computer only has 1Gb of RAM :). I read somewhere online about fixing by setting to 10Mbs/Full Duplex and it works I just don't understand why and it doesn't really help because im now only getting half my internet speed. It is like the drivers do not support the full connection. –  Arch Angel Sep 12 '10 at 10:36

3 Answers 3

up vote 0 down vote accepted

It sounds like you might have a power problem. I say that because of this phrase:

I need that PCI port for something else.

That tells me you've filed up your PCI ports. Every device you add to a system draws a little more power, and over time power supplies lose efficiency. Looking up the specs for your M1610, I see it has a measly 250Watt power supply. So, when adding and disabling the alternate network card, you could be changing out a heavier-load item for a lighter-load item. One way to test for this is to see if the onboard card works with the slot left empty. This could also explain why it works at 10Mbps - lower power draw.

share|improve this answer
    
the whole problem is because the onboard card doesnt work when the slot is empty. –  Arch Angel Sep 25 '10 at 8:19

Does removing the card also trigger some software uninstall? Then maybe some drivers are removed when you take out that card, if Windows is somehow oblivious about the onboard card using the very same drivers.

To fix that, maybe you can install the drivers again, after you removed that card?

share|improve this answer
    
already tried that not such luck, it's not a driver issue because windows detects the card just the card doesn't find the IP adress. –  Arch Angel Sep 6 '10 at 19:08
    
@Arch, what if you compare screenshots of the preference panes, with and without that second card? (To be very sure it's really not a different driver; there surely might be smarter ways to detect that...) –  Arjan Sep 12 '10 at 9:16

Try this: uninstall both devices in the Device Manager (Windows-R, compmgmt.msc), powering down, removing the card and powering up again. Windows should re-detect and re-configure the internal controller. If that doesn't work, right-click on the network connection in Windows and select Repair.

share|improve this answer
    
I have tried that, repair doesnt do anything, really strange considering the card is disabled. –  Arch Angel Sep 6 '10 at 19:08

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.