Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I created a trivial VB6 program for a friend about 3 years ago. I used the Package and Deployment Wizard to create the setup package.

Recently we reinstalled Windows XP on her laptop. We reinstalled all the software that she used before, but this program will NOT install. There was another program that failed in exactly the same way. It is also a VB6 program, and the author apparently used the Package and Deployment Wizard to create the setup program.

After running setup.exe from the ZIP file, we see a screen that says "Install" at the top, and "Copying Files, please stand by" in the main window. It seems to hang, and mostly locks up Windows. Eventually, I can shutdown Windows.

After I restart, I get messages about how the setup program was deleted, and did not finish completely. It also tells me about the ST6UNST.001 file in the C:\Windows directory. After looking at this log file, it appears that the setup program crashed shortly after the "bootstrap" section.

The failed install seems to put some sort of "lock" on the hard drive. As a result, we could NOT run any sort of disk scan (such as Norton Disk Doctor). When we tried to run chkdsk, it said we needed to schedule it and reboot. When the system restarts, it said "Windows cannot open volume for direct access".

To get around that problem, we had to boot the system from a Windows install CD, and then run chkdsk / R. It said it had to dismount the drive first, then it ran to completion with no errors. After that, we could run disk scans and such.

Since the initial failed install, we continued installing the rest of the software on the computer. It seemed to run okay for a week or so. A month later, this computer has become VERY flaky. Firefox often consumes memory without limit, and causes the computer to crash. Other programs (Microsoft Word, Thunderbird, Windows Explorer) report strange memory errors and strange DLL errors.

I suspect a hard disk problem, but the computer ran pretty well for the prior 18 months. I have Googled to try to find the cause of this failed install of the VB6 program. So far, I have not found anything conclusive.

We tried many things both before and after the initial install:

  • We disabled/exited all unnecessary software
  • We disabled Norton Anti-Virus during the install
  • We have run scans with Malware Bytes Anti-Malware
  • We have run scans with Norton System Doctor


Contents of file: ST6UNST.001

%% PLEASE DO NOT MODIFY OR DELETE THIS FILE! %% %% This file contains information about the installation of an application. %% %% It will be used to automatically remove all application components from your computer if you choose to do so. %%

NOTE: Beginning of the bootstrapper section

CONFIG: Title: "Mc-TagIt"

ACTION: RegKey: "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion", "SharedDLLs"

ACTION: SystemFile: "C:\WINDOWS\SYSTEM32\VB6STKIT.DLL" (File currently on disk was already up to date)

ACTION: SystemFile: "C:\WINDOWS\SYSTEM32\COMCAT.DLL" (File currently on disk was already up to date)

ACTION: SystemFile: "C:\WINDOWS\SYSTEM32\STDOLE2.TLB" (File currently on disk was already up to date)

ACTION: SystemFile: "C:\WINDOWS\SYSTEM32\ASYCFILT.DLL" (File currently on disk was already up to date)

ACTION: SystemFile: "C:\WINDOWS\SYSTEM32\OLEPRO32.DLL" (File currently on disk was already up to date)

ACTION: SystemFile: "C:\WINDOWS\SYSTEM32\OLEAUT32.DLL" (File currently on disk was already up to date)

ACTION: SystemFile: "C:\WINDOWS\SYSTEM32\MSVBVM60.DLL" (File currently on disk was already up to date)






NOTE: End of the bootstrapper section

share|improve this question
This is a long shot, but as a test of the 16-bit subsystem, try running SYSEDIT. Press Windows-R, then type sysedit and press Enter. Does the program's interface appear? – boot13 Sep 5 '10 at 17:14
I just tried this on my development system (4 GB RAM, running fine) to see what happens.It failed with this message: "The Win 16 subsystem has insufficient resources to continue running. Click on OK, close your applications, and restart your machine" .... I am surprised! – Rick G Sep 6 '10 at 2:32 seems to explain that problem. – SamB Jan 11 '11 at 19:02

My friend's PC became so unstable that we decided it was time to reinstall Windows - after only two months!! I reinstalled Windows XP on her laptop this week. This time around, I knew what to expect, so I captured several backup images along the way.

After lengthy analysis, the conclusion is that Norton Antivirus 2010 is the culprit. I tried turning off every option available, but the "plain vanilla" VB6 programs would not install. The setup bootstrap program hung and locked up the computer EVERY time.

I went back to the image I had created prior to installing Norton Antivirus 2010. Then I could install both of the VB6 programs with no difficulty. I think there must be some "one in a thousand" conflict between the Norton Antivirus 2010 and the Windows XP installation that was created by the Recovery partition on her Toshiba L300 laptop.

We certainly had no similar problems two years ago when we did the initial installations of these identical VB6 programs. Back then she had Norton Antivirus 2008 installed on the laptop.

She has Microsoft Security Essentials on the new Windows XP installation. I have tested it on some other laptops, and it does an adequate job.

share|improve this answer

Try installing it in safe mode, first you will have to run 1 command so the msi service will run in safe mode.

In the command window Type the following command and press Enter:

REG ADD "HKLM\SYSTEM\CurrentControlSet\Control\SafeBoot\Minimal\MSIServer" /VE /T REG_SZ /F /D "Service"

Restart the PC in safe mode and try the installation of the software.


share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.