Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Ok, so I've got this old self-build as my backup computer, with an A7N8X-E, an Athlon XP 2500+, and 2GB DDR-400.

It's been working since forever, running dual boot with Windows XP and Server 2003. Reliable as a reliable thing.

So I drop an Athlon 2800+ in, and it works fine. I drop an extra 1GB of DDR-400 in, and it still works fine. XP recognises the memory, I torture it for a while with Prime95, all is well.

Then, I think... ok, I have a slightly faster processor, 50% more memory, why not rebuild with Windows 7.

So I boot off my Win7-x86 CD (which I've used before), and dammit, it blue-screens after the initial "Windows is loading files" bit, just as the little graphics start their flying about thing.

In all, I try 3 sticks of memory (as the final extra 1GB), and they're all the same.

Finally, I pull the 3rd GB of memory, leaving just 2GB in place, boot off the CD, and the installation proceeds without a hitch.

I put the 3rd GB back in at the end, after it's all working, and it won't boot.

So. What in &$&%&$%%$^£$^%$^£%$%$^ is going on?

Bottom line: XP happy as Larry with 3GB, Win7 grumpy as hell. As, I might say, am I.

Any clues people?

Update...

Thanks for the suggestions so far... just to clarify...

There's the original 2GB, that worked with the original XP, and the new Win7. Then there's 3 sticks of mem from another PC that was also perfectly Ok with XP. It's these 3 new ones that I've tried one at a time with the new install, and none of them works with Win7.

I'll try a couple of them as an alternative to the original 2, and update soon. Thanks for bearing with me on this..

Update... SOLVED!!

I'm most grateful for all the suggestions here. In the end, following the instructions in this forum post sorted it all out.

In case that link ever disappears, here are the steps:

  • Find the "NVIDIA nForce2 AGP Host to PCI Bridge" in the device manager
  • Right-click and choose "Update Driver..."
  • Browse my computer etc.....
  • Let me pick from a list etc....
  • Select "PCI standard PCI-to-PCI bridge"
  • You will now have 2 listings of "PCI standard PCI-to-PCI bridge" and no NVIDIA nForce 2 AGP Host etc....
  • Click "Finish" and shutdown the computer.
  • Now install your RAM upgrade and power on.

After the reboot, Win7 now recognises all 3GB of RAM.

share|improve this question
1  
Is Windows 7 equally happy with any 2 of the 3 sticks being used? –  nhinkle Sep 5 '10 at 19:19
    
This workaround works only if you don't care about not having Aero or any accelerated graphics. The ultimate solution would be for NVIDIA to fix their driver or for someone skilled enough to fix it for them. –  Christopher Parker Dec 30 '11 at 22:28

3 Answers 3

up vote 3 down vote accepted

There is no solution to this problem. It's a bug in Windows Vista and later and nForce 2 chipset. Workaround is to remove RAM until you have 2 GiB installed.

EDIT Looks like Microsoft finally provided solution for it. Take a look at this forum post.

As a fellow owner of A7N8X-E motherboard, I was quite angry when I found out that the problem isn't fixed in Windows 7.

John T's workaround worked for me when I didn't want to remove the third stick (I was dual booting Windows 7 and Fedora at the time and GNU/Linux didn't have any problems with RAM).

share|improve this answer

I'd start off first by checking what the hardware sees.

Boot into the BIOS and see how much memory is detected there. Before exiting, reset the BIOS to defaults in case there are any lingering settings in there from when you had your old hardware. Run the system through Memtest86 for a couple runs with all 3GB in place, see how you fair.

If it still won't boot with all 3GB installed, grab the mini dump file and take a look at it with WinDBG to get some clues. I've heard of problems so silly as certain graphic drivers not liking the extra modules due to them using shared memory with the system. In such a case, a simple graphic driver update solves everything.

Another thing you can try is booting into Windows 7 with the 2GB and checking msconfig's max memory setting:

alt text

the box should be unchecked by default like mine but it's worth a look.

Tell us how you fair.

share|improve this answer

Run Memtest86 with all 3 sticks installed. It should let you know if there are any problems with the memory.

It is possible that there is a problem, but for some reason it doesn't effect XP in a way that makes it crash, but in Win 7 it does.

As nhinkle suggested, try mixing the sticks to find out if there is a problem with a specific stick, or possibly the motherboard.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.