Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm running Windows 7 and I have a 1TB Western Digital MyBook drive attached via eSATA. Whenever I connect via remote desktop, the drive seems to disappear. If I login to the system locally and reboot the drive, it shows back up again.

The MyBook drive in question is on a desktop computer. I'm connecting to the desktop from my laptop via remote desktop. So the drive on the remote system (desktop) is the one that is disappearing. Even after closing the remote desktop session and logging directly into the desktop, the drive is not there until I reboot the drive.

Any ideas on what is going on or how I can fix it?

Some additional information. If I have an explorer window with the drive open, the problem does not occur.

share|improve this question

migrated from serverfault.com Sep 5 '10 at 20:50

This question came from our site for professional system and network administrators.

    
Can you see the drive in your device manager? –  ZippyV Sep 12 '10 at 10:20
    
Did you check the power settings? –  imoatama Sep 16 '10 at 2:34
add comment

4 Answers

up vote 0 down vote accepted
+50

I would guess that this is a driver problem or conflict.

Two drivers are involved : video and perhaps hard-drive (if you have installed a driver or software for it).
You should update both, downloading drivers from the manufacturer's website.

You should also run Windows Update on both computers, with attention to optional hardware-related updates.

If your laptop is not running Windows 7, ensure that it has installed Remote Desktop Connection 7.0.

share|improve this answer
    
I'm accepting this answer because the Remote Desktop Connection 7.0 installation on the laptop has greatly improved the situation. It's working 90% of the time now. There is still something else going on, but I'm not sure what. Will follow-up after I've tried some of the other suggestions. –  Keith G Sep 16 '10 at 14:32
add comment

There are checkboxes on the Remote Desktop client side that specify whether or not remote peripherals are mapped to the session or not. It's a bandwidth saving measure.

To access your drive, before you connect, in 'Remote Desktop Connection', you expand 'Options' then go to the 'Local Resources' tab, press the 'More' button toward the bottom, expand the 'Drives' tree, and check the box for the eSATA device.

share|improve this answer
    
I'm not necessarily interested in connecting to that drive via remote desktop. I'm interested in preventing the remote desktop session from making the drive disappear all together ... even when I log back in to the console. –  Keith G Sep 7 '10 at 16:15
    
You've got it the wrong way around - the 'remote peripherals' in this case would refer to the drives on the laptop. The question refers to a drive connected to the desktop. –  imoatama Sep 14 '10 at 2:38
add comment

Is this a rdp login to a new session or a disconnected session? Sometime a disconnected session will not effectively show resources when you login again.

Are you saying the drive disappears on the actual machine it is connected to?

If you are seeing it after a reboot from the remote machine it may actually be you just logging in again that is re-reading the resources in a new session. A way to test this is to logoff (not just disconnect) from the remote connection, when you see the drive missing. If logging back in makes it show up the same way rebooting does, it is related to your session.

If the remote connection actually removes the drive from the machine it is connected to, it is likely drivers, as mentioned by harrymc.

share|improve this answer
    
I am saying that the drive disappears on the actual machine it is connected to. I've got it working pretty reliably now after installing the Remote Desktop Connection 7.0, but it's still not 100%. I don't have time to investigate session state fully before the bounty expires, but I will follow-up after I've tested it. –  Keith G Sep 16 '10 at 14:30
    
if that is the case I would suspect the drivers. We had a usb drive that server 2003 always that windows determined it could improve the performance on, and so it would automatically upgrade the drivers and make it disappear, which is very likely what you are having happen. –  datatoo Sep 17 '10 at 4:01
add comment

A few things to try:

  • Check the event logs for anything around the time the drive disconnects.
  • Check Device Manager to see the driver is installed properly
  • If you're using an NVIDIA chipset, install the hotfix referred to in this KB article
  • Install your motherboard manufacturer's drivers for the eSata controller if they exist (background on this)
  • Check the "Power settings -> Turn off drive after X" setting, in particular for the user you're logging into remote desktop under.
share|improve this answer
    
Nothing in event logs. Device manager looks good. Looks like the NVIDIA fix is for USB devices, and I'm connected via eSATA. Already checked power settings, and that didn't make a difference. I will also check the other link related to motherboard's drivers. –  Keith G Sep 16 '10 at 14:36
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.