Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I get something like:


   ~~~~~~~~~~~~~~~~~~~~~~~~~~| DirectFB 1.2.10 |~~~~~~~~~~~~~~~~~~~~~~~~~~
        (c) 2001-2008  The world wide DirectFB Open Source Community
        (c) 2000-2004  Convergence (integrated media) GmbH
      ----------------------------------------------------------------

(*) DirectFB/Core: Single Application Core. (2010-06-30 18:13) 
(*) Direct/Memcpy: Using Generic 64bit memcpy()
(!) Direct/Util: opening '/dev/fb0' and '/dev/fb/0' failed
    --> No such file or directory
(!) DirectFB/FBDev: Error opening framebuffer device!
(!) DirectFB/FBDev: Use 'fbdev' option or set FRAMEBUFFER environment variable.
(!) DirectFB/Core: Could not initialize 'system_core' core!
    --> Initialization error!
Could not initialize graphics driver directfb:
Initialization error!

when I launch (i.e.):

$ links2 -driver directfb

Any ideas?

It's a brand new thing for me, maybe I'm misunderstanding some basic concepts.

share|improve this question

1 Answer 1

You need to load the appropriate frame buffer module for your video card first.

share|improve this answer
    
Can you be more specific (examples, howtos)? I've got an ATI video card. –  cYrus Sep 5 '10 at 23:36
1  
modprobe radeonfb –  Ignacio Vazquez-Abrams Sep 6 '10 at 0:01
    
Tried that, same issue. The device /dev/fb0 still doesn't exist. –  cYrus Sep 6 '10 at 17:07

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.