Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I been having this random dns problem, in Ubuntu 10.04 and in 10.10 it started about 2 weeks ago after (I believe) an update.

Basically when I go to a website randomly I get that the website I'm visiting is not available ("Oops! Google Chrome could not connect to ..." & "This webpage is not available.").

I tested with Chromium "7.0.515.0 (58587)" and Firefox minefield (4.0ish) and 3.6.9.

I did these 4 things already:

/etc/default/grub GRUB_CMDLINE_LINUX="ipv6.disable=1"

and this:


net.ipv6.conf.all.disable_ipv6 = 1 net.ipv6.conf.default.disable_ipv6 = 1 net.ipv6.conf.lo.disable_ipv6 = 1

*disabling Chromium DNS pre-fetching

*using Google and OpenDNS servers as well as ISP DNS servers.

But didn't improve, also no other computers in my network have the same problem. All computer wired to the same router.

I'm a software engineer that run out of ideas, please help me.

Thanks in advance.

UPDATE: some programs (synaptic / firefox update/ vuze(azureus)) say connection refused for the error. Most of the time a second try will fix the "refusal".

UPDATE2: I found out with Wireshark, that everytime I have this problem i've got this ICMP Destination unreachable (Port unreachable)

Confirmed an ISP error. ISP;Speedy Location: Argentina, Buenos Aires (capital Federal) Area.

share|improve this question
Are you pulling an IP address via DHCP, or do you have a static IP? When you say that you are randomly seeing the "oops..." messages, does that mean randomly while accessing one site - or randomly accessing various sites? Can you give examples of sites that work, and one's that do not? I'd rule out search domain issues, etc. – Matt Sep 6 '10 at 15:21
Static IP (Always), but also tried with a DHCP given IP. Same thing happens with various sites, from google to xda-developers, it doesn't matter which site. – OmniWired Sep 6 '10 at 16:34
knowing your DNS servers from the entries in /etc/resolv.conf, is dig @<DNS-server> giving you any (random) errors? – MaoPU Sep 7 '10 at 8:47
No, I don't get random errors, this is what makes me think is a lib error. – OmniWired Sep 7 '10 at 18:06
up vote 1 down vote accepted

This problems happen when a ISP don't do their job properly.

Basically the transparent proxy sends a RST response and cuts the TCP session.

The workaround is to use a custom made proxy that retries when the RST flag is detected.

This is the proxy:

I hope this fix the problem for other problem, in others countries maube, with the same problem.

I feel the need to say that this doesn't fix the problem, given that the issue is in the "transparent proxy" that runs the ISP. But this stops the problem by making a re try attempt automatically.

This is the IPTABLES WAY:

iptables -A OUTPUT -p tcp --dport 80 -m state --state NEW -m recent --set --name thor --rdest -j ACCEPT
iptables -A INPUT -p tcp -m tcp --tcp-flag RST RST -m state --state ESTABLISHED -m recent --name thor --rcheck --rsource --seconds 1 -j DROP
share|improve this answer

Have you tried powercycling the router/modem yet? Yes, I know, its not ubuntu-specific, but it could be causing these sorts of errors.

share|improve this answer
no fix, the same machine in windows works fine. Maybe is a ISP provider? even if i'm not using their DNS servers ? – OmniWired Sep 15 '10 at 23:57

If you are having problems with your ISP, you could try some third party DNS servers. For example there is OpenDNS and Google Public DNS.

share|improve this answer
you should read the post again.(is written that I'm using those DNS) This is a problem (it seems) with the transparent proxy... some people say. Maybe is at the transport layer, who knows... – OmniWired Sep 25 '10 at 11:10
Why did you answer to use what he said it wasn't working? – Saikios Sep 26 '10 at 20:08

Googling my own DNS problem, I came here. None of the above helped me. We moved our webhost to a new, dedicated server and nothing could find it from the LAN. /etc/hosts changes weren't working, nothing.

Our firewall server has bind9 and in /etc/bind/, there was a file with the domain as part of the file name. I edited that reflecting the new IP. Now nslookup works correctly for us.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .