Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My laptop (as a host) has Windows 7 Home (Premium?). The guest is Windows 2003 Server. The problem is this - Internet works fine from the host, but not from the guest.

Now, if I move the guest VM to my desktop (where the host is Windows XP), internet works fine.

Additional information, the desktop connects to Internet via LAN, however, the laptop connects via Wireless.

What could be the problem? How to fix it?

share|improve this question
add comment

1 Answer 1

VMware Player and Workstation has a few different connection methods.

One of which is NAT networking, this simply shares the current host network connection with the guest and unless you set up port forwarding, it does not directly accept incoming connections. As far as other machines are concerned, the network connection is going to the host.

On the other hand, Bridged networking (which I assume you are using) is the equivalent of splitting your network card in half - as far as the rest of the network is concerned, it is a separate fully accessible device on the network.

If you are sharing the network in Bridged mode and over Wireless, you have to remember that whilst it should still physically connect to the router/access point, it will most likely be subject to the same restrictions you have on other devices such as MAC filtering.

Check the security settings on you router/access point, and if you are still having problems - and are not directly accessing/hosting through the VM, I would suggest you change the networking mode to NAT.

share|improve this answer
    
Wil: No, I am not using Bridged Networking. In my VM Player, right at the top if I pull down a drop-down titled Ethernet, I see NAT selected. –  Kanini Sep 15 '10 at 15:41
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.