Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to run Robocode on ubuntu linux. Normal java version works fine, but I can't force it to read dll files containing robots written in C# (see .net plugin)

After installing .net plugin I tried to run robocode like that:

java -Xmx512M -Dsun.io.useCanonCaches=false -cp libs/robocode.jar;libs/jni4net.j-0.7.1.0.jar robocode.Robocode $*

But it seems it is not working - the robocode runs, but still doesn't read the robots from dll files.

Any ideas?

share|improve this question
    
You might need a .NET runtime such as mono. –  grawity Sep 6 '10 at 19:26
    
I have it already. –  Gacek Sep 6 '10 at 20:06

1 Answer 1

up vote 0 down vote accepted

Robocode is using jni4net as bridge to .NET. jni4net doesn't support unixes/mono yet. More in this thread

share|improve this answer
    
Did this change in the past two years? –  Paul Apr 11 '13 at 21:03

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.