Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When I right click the ISO file it doesn't show the burn option anymore...

how to launch the Windows Disc Image Burner?

share|improve this question
    
On my Windows 7 Ultimate machine, right-clicking an iso file shows the burn disk image option. On my Windows 7 Home Premium PC, it does not. However, its "Open with..." option has "Windows Disc Image Burner" that works just as well. –  Hong Nov 20 '12 at 14:02

8 Answers 8

up vote 2 down vote accepted

You can also install the application called ISO Recorder. V3.1 now supports Windows 7 and 64 bit.

share|improve this answer

Click Open, when the dialog box pops up stating that it can't find an appropriate program, Click Select a program from a list.

Windows Disc Image Burner will be in the list. Ensure the Always open this file type with this program box is checked and click OK.

share|improve this answer
    
I had the same problem. My .iso files were associated for some reason with the windows common shell. Doing what's suggested here worked for me because it associated them with the image burner and as a result r-instated the context menu item. –  user63723 Jan 19 '11 at 5:17
    
Either that or right click and select Open with –  Tobias Kienzler Mar 27 '13 at 17:49
    
Windows Disc Image Burner doesn't show in list of programs. Where can I find it in Explorer? –  JohnK Aug 20 '13 at 21:13

You're probably missing the "Burn disc image" Shell menu option because some other program overwrote the Default association for .ISO file types under HKCR.

You can fix it manually by changing the value for the (Default) key under HKEY_CLASSES_ROOT\.iso to Windows.IsoFile

Once the change is made you can either restart Explorer or just log off and log back onto the machine.

share|improve this answer
    
I didn't have that key, so I resolved by: Start > Run > regedit.exe > navigate to HKEY_CLASSES_ROOT > check if there's a key beneath that called ".iso", if there's not then right-click on HKEY_CLASSES_ROOT > new > key, name it ".iso" > click on ".iso" > double-click on "(default)" in the right-hand pane > type "Windows.IsoFile" > ok. Close & reopen Explorer windows and hey presto, there's the Burn Disc Image in the right-click menu. –  Rory Sep 3 '12 at 12:50

It's called isoburn.exe and is located in your System32 folder. So if it loses the association, you can Open With... and "Browse", go to C:\Windows\System32\isoburn.exe and make it open it with that from now on.

share|improve this answer

I'm not sure how to launch the Windows Disc Image Burner manually, but you should be able to install the free version of DeepBurner, and use that to burn the ISO. If you use that, and can't find the burn button, try resizing the window.

share|improve this answer

Does the file still have the '.iso' extension?

If it doesn't show an extension, open an Explorer window and naviagte to;

Organize > Folder and Search Options > (Tabs) View > Uncheck 'Hide Extensions for known file types'

Now if the extension is not '.iso', rename the file and replace whatever it ends with to '.iso'.

Now it should be recognised as an ISO file and be opened appropriately. You may want to check the 'hide extensions' setting again if you profer it this way.

Hope that helps.

share|improve this answer
    
That's not the cause in my case –  Jader Dias Sep 6 '10 at 20:41
    
@Jader Dias What version of Windows 7 are you running? I've just checked myself and I cant find the Disk Image Burner either. Im running Home Premium. Maybe this feature is only available on Professional or Ultimate versions? I definately remember using that feature in the Windows 7 beta, which was the Ultimate edition. I could be wrong, but its plausible. Ill see if there is anything about it on Microsoft's site too. –  Connor W Sep 6 '10 at 20:51
    
I'm using a Home edition –  Jader Dias Sep 6 '10 at 20:52
    
Ok, after some searching I found this: windows.microsoft.com/en-GB/windows7/… It says in the top left that this applies to all editions of Windows 7, so it must be something else causing a problem. Do you have any third-party disk burning software on your PC? I do, and im wondering if that has disabled the default Windows disc buring feature? –  Connor W Sep 6 '10 at 21:02
    
yes, I have UltraISO installed –  Jader Dias Sep 9 '10 at 11:35

Simplest way to just burn files is to right-click on the file and choose Open With-> Windows Disc Image Burner.

If you ever want to restore .iso association, the you should select Open With->Choose default program and select Windows Disc Image Burner from the list.

EDIT

Here's another way to start isoburn which bypasses file associations.

Copy the .iso file to a easily accessible location first, like C:\ for example. In this example, I'll assume that the recorder is on drive D: and that .iso is on C:\my_iso_file.iso

Then go to: Start menu-> type cmd into search->cmd.exe

Once it is open type following into terminal:

isoburn D: C:\my_iso_file.iso

This will start Windows Disc Image Burner set to burn my_iso_file.iso using recorder at drive D:. Using GUI, recorder can be changed, but the file being written can't be changed.

share|improve this answer
    
There is no such option for me –  Jader Dias Sep 6 '10 at 20:41
    
@Jader Dias Then something is seriously messed up if you don't have open with option. You could try changing file's extension to something random like FTW for example and double-click on it. It should open up dialog which should let you select program to be used to open the file. Open it with C:\Windows\System32\isoburn.exe The "there is no such option part" is a big problem. Are you having virus problems or something similar? I've never heard of open with option being disabled. –  AndrejaKo Sep 6 '10 at 21:04

Try this:

Right click your iso file -> send to -> DVD RW Drive (or something like this)

share|improve this answer
    
This will write the iso as a file –  Jader Dias Oct 5 '10 at 13:33

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.