Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Suddenly when i right click on images the first option is edit and double left click causes images to open in MS paint. After using this solution i see irfanview still messed up. When i left click it opens irfan once again however i get 0/1 or 1/1 images and i can no longer go to the previous and next image.

I tried setting the file assoc by opening irfan in admin mode but i dont understand how to (I click ok but it doesnt seem to work and no button that 'sets' it). How do i set file association/Allow going to next/prev image?

share|improve this question
add comment

3 Answers

up vote 2 down vote accepted

In IrfanView, you can go to OptionsProperties/SettingsExtensions to change the file associations. IrfanView has two types of file associations:

  • A. File associations that let you double-click on file icons in Explorer to open files in IrfanView.

  • B. File associations that let you browse previous and next files in the same folder within IrfanView and IrfanView's thumbnails viewer.

enter image description here

To set the type A (open) associations, check the boxes for the file types you want and click OK. If you're having problems setting the type A associations in Windows Vista or Windows 7, the text at the top of the settings box suggests you might need to start IrfanView as administrator. (In the Start menu or Desktop, right-click on the IrfanView icon, and select Run as administrator.)

To set the type B (browse) associations, you can do one of the following:

  • Select the option Load only associated types while moving through directory. This will make the type B associations match the type A associations (the check boxes on the top of the Extensions page).

OR

  • Select the option Load custom file types. In the text box, enter the file extension of each type of file you want IrfanView to browse. Separate the extensions with a vertical bar |. To make it easier to see all the text, you might want to open a blank Notepad window, copy the text to Notepad, edit it, then copy it back to the text box when you're done.
share|improve this answer
    
I double checked it was set to A. Then i hit clear all then select only images and hit ok. AFAIK nothing was changed but it lagged when i hit OK so it looked like it actually applied the settings. Now it works like it did. I think i HAD to clear all,select image even tho nothing changed. Anyways this works so you got the answer. –  acidzombie24 Sep 7 '10 at 1:07
add comment

Read down farther in that solution and you'll find my recommendation: "Nirsoft's freeware FileTypesMan is handy for sorting out this kind of problem." I stand by that earlier recommendation.

share|improve this answer
add comment

Try reinstalling irfanviewm, and when it gets to the point where it asks you for file associations, click the "images only" button. That will set all images to open in irfanview.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.