Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I migrated music files from my old Mac to my new Mac but I don't have the permissions to open the folder with the new files. The option to select the folder with the transferred files was grayed out when I used "Get Info".

share|improve this question
add comment

3 Answers 3

If you want to do this properly, you should check out this guide at apple.com.

If you want to change permissions of specific files/folders manually, you can use the chown unix command.

share|improve this answer
add comment

It does not sound like you are comfortable with using the command line so here is a GUI based solution that you might try:

If you are able to Get Info on the folder of interest go the the very bottom section Sharing and Permissions.

By default this section is greyed out for all files/folders regardless of the owner/permissions. You can gain access to this area by clicking on the lock ion in the lower right corner of the Get Info window.

Once you have input the admin password for the computer you should be able to edit the permissions on that file/directory.

You can recursively apply the changes made to the permissions by selecting Apply to enclosed items from the gear shaped dropbox in the lower left of the Get Items window.

If you are familiar with the command line there are alternatives to this approach but give the graphical method.

share|improve this answer
    
Of course it was hidden behind the gear icon, where all critical options should live. Thanks –  Dylan Valade Jan 17 at 15:45
add comment

Click "get info" for the folder/file in question and then in the window that opens, look at the bottom right of it.

There should be a padlock item next to the file permissions area. If the padlock is displayed in the "Locked" position, then click it ones to 'unlock' it, then the file permission sections should no longer be greyed out.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.