Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm using Ubuntu and I have a Samsung Syncmaster 2232 monitor, which is a 22" widescreen. I also have version 185.18.14 of the nVidia video driver, running on an XFX GeForce 6200.

My problem is that while the driver works at my monitor's native resolution, (1680x1050) for some reason it always goes back to 1600x1024 whenever I reboot the system. I've used the nVidia software to save the settings, but it always goes back. It's even in /etc/X11/xorg.conf as 1680x1050, so I have no idea why it goes back to the other resolution.

Any hints?

share|improve this question
2  
This should be tagged "xorg" as well. –  Chase Seibert Aug 13 '09 at 2:36
add comment

6 Answers 6

When you use nVidia's display manager, make sure that you start it with root permissions, and tell it to write out the changes to the xorg.conf

share|improve this answer
    
Ok, I'll try that but that doesn't explain why the 1600x1024 resolution is not in the xorg.conf file. –  Ernie Dunbar Aug 5 '09 at 16:10
1  
its likely that for some reason EDID is probing your monitor wrongly during X starting, and the automatic resolution thing it does ( check your log ) is deciding the resolution doesn't work in advance wrongly. –  Kent Fredric Aug 5 '09 at 18:37
    
Nope. Didn't work. @Kent: searching for EDID (with grep -i no less) or 1600 in my boot log doesn't come up with anything at all. –  Ernie Dunbar Aug 6 '09 at 15:44
    
Can you post the device section of xorg.conf? –  Chase Seibert Aug 13 '09 at 2:37
add comment

I could be terribly wrong here, but I don't think that your xorg.conf is to blame.

Check the settings in System -> Preferences -> Display

If that menu entry is not present, it is either disabled in the menu or the required package is not installed. You need to run gnome-display-properties which is included in the gnome-control-center package.

And if you are not using Gnome, just forget everything I just wrote.

share|improve this answer
    
I am using Gnome, but I don't have "Display" under System -> Preferences. –  Ernie Dunbar Aug 6 '09 at 15:38
    
Try running gnome-display-properties from the shell. –  innaM Aug 6 '09 at 16:02
    
And if that doesn't work, install the gnome-control-center package which contains the display applet. –  innaM Aug 6 '09 at 16:03
    
Typically if the nvidia binary driver is installed, opening this menu will refer the user back to the nvidia settings app. –  Chase Seibert Aug 13 '09 at 2:38
add comment

I'd try installing the nvidia drivers from their website, as opposed to any packages that are in the repositories. Note that you'll need to have the kernel header files in order for it to install.

share|improve this answer
    
Yes, I did that. That's why I'm using version 185.18.14 of the nVidia driver, rather than 165 or some such that comes with Ubuntu. –  Ernie Dunbar Aug 6 '09 at 20:51
add comment

Try going into "System -> Adminsitration -> Log File Viewer" and looking at Xorg.0.log. Hopefully some of the info there will shed some light on the subject. Perhaps you could update the question with the contents of this log?

share|improve this answer
add comment

As mentioned in some comments, it is possible that your monitor outputs incorrect EDID information which may confuse X.

Try adding

Option "UseEDID" "FALSE"

to

Section "Device"

section of your xorg.conf. (Specifically, the one with an Identifier you are using; presumably the one with Driver "nvidia".

This requires that you manually enter information (HorizSync/VertRefresh, DisplaySize) for your monitor. I'm not sure if this has changed with modern LCD panels; I still use a CRT at home...

If this doesn't work you should remove that line; most monitors get this right.

share|improve this answer
add comment

I've been having similar problems for some time. Today I added a new user account, and that account immediately gets the correct resolution (1360*768 in my case) whereas my usual account still requires a visit to nvidia-settings every time I log in.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.