Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When Greasemonkey is enabled, firefox displays XML responses as gibberish, eating all the tags and just leaving the text nodes. View source fixes the problem, disabling Greasemonkey does the same. I'd rather not have to do either. I want it to just not mess with XML responses (The url is a localhost address).

share|improve this question
add comment

1 Answer

up vote 2 down vote accepted

I do not use Greasemonkey, but it should be a simple matter of locating the script that's responsible for it and modify it to ignore localhost or even more specific URLs.

You can disable Greasemonkey scripts from the menu: Tools → Manage User Scripts, and in the dialog of "Manage User Scripts" deselect the Enabled checkbox for all scripts that you suspect are responsible, until the problem disappears. See the video How to disable a user script.

Once you find the script, either keep it disabled, or modify it. You can also uninstall a script from the above dialog.

share|improve this answer
1  
Agreed, Greasemonkey itself doesn't do this (at least not when I used it). –  Sasha Chedygov Sep 7 '10 at 6:37
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.